< Back to IRCAM Forum

OM for Windows, old versions

Hi All,

Please, I should need a little help: a student of mine has some problems with last OM version in Win 10, probably related to OMAudio lib.
Is it possible to download and test old Open Music versions?

On Github oldest version is 6.15, I was searching for older ones.

Thank you all in advance, ciao

fdsdb

Hi Fabio.

Sorry can’t help much with the old versions of OM for Windows. But perhaps you could provide some more info about the OMAudioLib related stuff: versions, where it came from, messages etc…?

Thanks!

-anders

Dear All,
Yes we are aware of the windows 10 issue. Fot he time being we don’t have a working windows station, but it will come soon and the problem will be dealt with ASAP.

@Anders, i don’t think it is related to the omAudiolib itself, it just have to be recompiled and updated in visual c++ windows environment. The reason I say so , the problem is happening also with the sdif.dll. So it is a issue with the loading of these dll on windows 10. For other windows versions it is ok.

@Fabio, we will try the best to recover the former version of OM. As Jean stated, they unfortunately disappeared since the new forumnet site was put in service.

Best
K

Hi All,

First thank you for fast replies.
Meanwhile I have receive a mail from my student: she has installed Ubuntu 19.10 and OM 6.16, but, I suppose in starting OM, she receive this error

I hope this can be generally useful, even if not windows related.

Ciao

Fabio

Ok,
too bad, Om was tested with the 18.x version of Ubuntu.
I will install this latest version, test and will be back to you.

Best
K

Hi Fabio,

Very strange, just installed Ubuntu desktop 19 on a vm, everything seems to work fine.
Are you sure she installed the latest version of OM, i.e version 6.16 ??

Hi there. I just uploaded OM 6.16 installer for Windows:

Hi Karim,

Yes, the student told me she installed OM 6.16.
Now she has installed Ubuntu on her laptop, but this morning I have received a her mail saying that as alternative solution she could run Win 7 from a usb pen, so to use OM in that OS.
Unfortunately at the moment I have not had the possibility to assist her more directly, so I hope I am exact in explanations and news. I will give a more exact feedback as soon as we can get in touch in our Institute.
Meanwhile many thanks to you all for support.

Ciao

Fabio

P.S.
Only for sake of clearness: the problem started because this student is the only person of the course (composition for didactics) to have a tablet, an Apple one I suppose, so she recovered an old computer for following the course using OM.

Dear Fabio,

I don’ think it is a good idea to work on a win7 on a usb stick. Ubuntu 18 or 19 versions work good with the latest OM version. I suspect that the installation of ubuntu by your student was not that clear. Or, please can we have more info about the specs of her laptop. (processor wise ie.)
So maybe better to stick with the ubuntu solution.
Keep me posted.

Best
K

Hi,

Just for info. Fabio’s student is not alone. I’m in Ubuntu 19.10 and with OM6.16 got the OmAudiolib error. In my case, this error appears every time I upgrade OM version, so I keep a self compiled omaudiolib that I replace on each installation.

best regards,
rc

Dear rc0

Can you be specific about your hardware concerning this problem?
What is your machine processor, etc…

Thank you
K

Dear Karim,

My student has sent me her computer specs, by following image.


I hope it can be useful. She has tested also on Fedora 30, but without success.
I hope next Friday to have the opportunity to get in touch with her and to have time to try to resolve.
If I succeed I will say you, menawhile thank you for help.

Ciao

Fabio

Dear Fabio,

According tour friend dev @ ircam it is as i suspected, it’s due to the processor type. But this is not an issue. We will try to recompile omaudiolib in order to be more and more universal.

Best
K

Dear Karim,

Thank you very much, if we succeed in resolving I will inform you.
Really my student was thinking about changing the computer…
Unfortunately we go slowly because we are not in Institute all/same days.

Ciao

Fabio

Dear Fabio,

Apparently, this is due to the old processor (celeron). So you need to compile the omaudiolib on the machine and replace it. We will deal with this issue in the next release so that it works on most 64bit processors.

If you need assistance, don’t hesitate.

Best
K

Dear Karim,

here’s the output of lshw.

best regards,
rc

hwlist.html (71.9 KB)

Dear Karim,

Thank you. Today I should get in touch with the student, and if I have sufficient time during my pause I will try to compile the library on her computer. I will keep you posted about it.

Ciao

Fabio

Dear Karim,

We have resolved for the moment in this manner: my student has installed Fedora 30, and I had a compiled (on my Fedora 30 if I remember good) version of OM 6.13, that runs on my student’s computer. sdif lib doesn’t not load (probably it should have to be compiled), but for my course this is not a problem, so we can proceed.

Thank you all for help, ciao

Fabio