< Back to IRCAM Forum

OM problem to launch on Windows

Hi, I have a problem to launch OM on my PC. I’m using Windows 10.
What should I do?
Print screen attached.

2018_12_10_16_29_49_Window.png

Hello Bolhomme

Have you checked if the file OMAudioLib.dll is correctly installed in C:/Program Files (x86)/OM 6.14/ ?

—Jean

Hi, yes, it’s in.

Everything is in C: (not D:/ or other external device ?)

Did you try to uninstall / re-install ?

Yep, did all that, and everything is on C

Do you have a previous version of OM working on this computer?
If yes, you could try to copy OMAudioLib.dll from there.
Otherwise you can get in in the archive section of the download page.

No it’s the last version and I had no other one.

you can get OM 6.12 for Windows here: http://forumnet.ircam.fr/shop/fr/archived.php?id_product=43&archived=1

Hi,
I’m having the same problem in windows 10.
I installed om6.15 from
https://github.com/openmusic-project/openmusic/releases/download/v6.15/OM-6.15-Windows-Installer.exe
The OMAudioLib.dll is there but it doesn’t work. Also the link of the last post is gone.
Best regards,
rc

omaudiolib

Dear rc

here is a recompiled omaudiolib for windows 10 (untested on windows 10 - because i don’t have it).
Now , remove the old omaudiolib to somewhere else, and replace it with this. I hope it will run.

Best
k
OMAudioLib.zip (524.8 KB)

PS: I will see if i can do the same with the SDIF ddl when i can get my hands on the sources.

Thanks for the file. I tried it but I still have the same error message.
best regards,
rc

Is OM 6.15 installed on C:\ ?

Dear rc,

If you tried the new omaudiolib, you can set back the old one. I assume it is not an om issue, but this should come from your windows installation. It could be:
1- Do yo have a MEAN anti-virus installed ?
2- Did you check your system for viruses ?
3- Are you administrator of your machine ?
4- As Jean says, is OM installed on your C:// Volume ?
best
K

Hi,
(sorry for the late reply. I haven’t got any notification about this topic)
I made a clean install of windows 10 ltsc 2019. No viruses were found.
Yes, installed in C: as an administrator.
Is there a way to test system compatibility or possible install errors?
Where can I get old versions of omaudiolib?
best regards,
rc

Have you tried to just re-run the installer ?
The problem here seems to be that the file OMAudioLib.dll is not found (and same for your sdif.dll)

Jean

Hi,

Just installed latest version windows 10 64bits, and i can confirm, the dlls are not recognized. Even if we re-install OM, and certainly when the correct location is present.
Will continue investigation.

Best
K

Thanks for testing it. I hope there’s an easy fix for this one.
Best regards,
rc

Just a note: the distributed OM 6.15 for Windows, as well as all linked libraries, are 32-bits. In principle this should be no problem, as Windows 64 supports both 32 and 64 bits programs, but this is something to be aware of, for instance if you recompile some of the dependencies.