< Back to IRCAM Forum

OM crashes systematically on Ubuntu 21.10

I will, though please note that all the previous problems occured without using midi or using any sound, just editing patches, maybe the midi configuration was making problems.

Hi Karim,
I’m attaching the setting of my Midi setup.
The crashing (OM not responding) happens in different moments, sometimes it’s just after a few seconds of working, sometimes a few minutes, so I can’t point an exact time of occurance.

Midi out is working (I can play), my input is always disconnected.

When using sound I run Qsynth, however I had this issue without Qsynth and without using sound.

Maybe changing the midi ports?
Looking forward to more hints…

Dear Amichail,

No it indeed appears not to be a MIDI issue.

  1. Are you sure it is not a read/write access issue?
  2. Does this happens with a particular patch, or randomly?

I will test on my side your workspace on my Ubuntu VM and see if i get this problem.

Best
K

So far so good. I succeeded to open and mess a little with most of the patches, without OMTristan library. I suspect that the troubles is related to it. As i can see from your preferences (libraries section), you have this installed. Is it autoloaded? if yes please uncheck this library and try again. If loaded and you seem to have trouble, it could be that you are not using the latest distribution of this library.

Best
K

Hi Karim,
So I tried deleting all the libraries and not loading any library on start-up, I still have the same problem…
any more ideas of what might be causing this?

Hi,

  1. Quit OM
  2. open the workspace’s folder
  3. remove both the wsparams.lisp file and preferences.lisp file
    Restart OM.
    this might fix the issue.

Another issue, while checking out the syslog you sent, most problems come from the
Workspace/elements/tp2(autour-de-vivier).omp

If you try to remove it and test again.

best
K

(Coming in late here, pardon me if this is already explained above).

I’m sure you’ve tested this, but just in case: do you get the same behavior with an empty workspace?

-anders

Hi and thanks for the suggestions,
I tried deleting wsparam and preferences - same issue.
The issue started long before working with tp2.omp, this happens to be the patch I’m working on now.
I tried starting a new workspace - created a patch and shortly after have the same issue.

In the last two days I’ve had a new issue: after aprox. 10 times of restrating OM (due to this issue) OS stops responding, I have to restart the computer.
This happens only with OM.
Is there something in OM on Ubuntu that could be causing CPU over usage?
All files and software are on the computer’s drive.

Any more ideas?

Hi amichai,

Wait a minute, is your system (Ubuntu) on the hard drive, or is it on the usb key which is always present in most of your screenshots?
or, have you a particular setup here?
I have worked more than 20 minutes on the vm ubuntu in order to simulate your problem, but didn’t. So I suspect, it is something pin your peculiar setup. Am I wrong?

Best
K

Ubuntu is on the hard drive, OM runs from the hard drive as well. The mounted drive on the screen shot is probably the sound interface (Scarlett). I had the problem before using the Scarlett so I don’t think it’s causing the problem…
In other words OM is running like all other apps on my computer, all from the hard drive.

Yes, I assume there’s something in my setup if you manged to work 20min on VM…
I just can’t figure out what’s going on.
Previous versions of Ubuntu + OM worked fine, I’m running it now just like any other app, it’s a simple setup, plenty of RAM and CPU power…

Hello Karim,
Just to update you: I tried running OM on Elementary OS (OS from USB) and it worked fine, no problems, I then tried with Pop OS (based on the Ubuntu 21.10) and I had the same problem. So now I have a dual boot with Elementary and I can work fine. I suspect it’s something with Ubuntu 21.10 (maybe on my computer…or in general), in April the new LTS is coming out and maybe it’ll be solved. Elementary is based on ubuntu LTS not the latest…

Best and thanks again for all the help trying to solve this,
Amichai

Dear Amichai,

Thanks for reporting. I use personally Debian (i am on a stable distribution). And everything’s working. What is strange, is that Ubuntu is a Debian based distrib. So I don’t know. Maybe if you change your window manager from Gnome to something else (more light ) such as Xfce, maybe things will run more smoothly. It is just a guess.

Best
K

Hi there

I would like to register that I was facing the same issue Amichai related on this post, with persistent crashes on either OM 6.20 or OM 7.1, with no apparent action within patches-related cause, using Ubuntu 22.04 LTS. It was very frustrating, especially considering that it was running just fine on Ubuntu 20.04 LTS and the problem only appeared after upgrading the OS.

After following Karim’s indications to untick Tooltips option and OMTristan autoload it seems to be working with no random crashes so far. More than 30 minutes of continued use of OM 6.20 on Ubuntu 22.04, and no crashes until now - previously it was lasting no more than 10 minutes before a new crash.

Hope this can help someone facing the same problems in the future…

Will test with OM 7.1 later.

Thanks!

Hi priosfilho,

Thank you for reporting this. I suspect that this is related to some window decorations in Ubuntu that have changed as default. Will try it on the latest release of Ubuntu.
Please keep us informed.

best
K

Hi Karim

Unfortunately, the random crashes continue happening either in OM 6.2 or OM 7.1. Sometimes just after a few minutes of plain use… It seems to be independent of a specific type of action but I think I can affirm that it happens in reaction to (random and diverse) actions within OM. (I can report at least some instances: duplicating objects, pasting objects, inserting comments, opening score objects) When I reopen OM I try to replicate the problem by redoing exactly what I did when the last crash happened, but it doesn’t crash until it (apparently) randomly decides to do so, this time after a new action.

I’m on a HP 15-bs0xx Notebook
16GB RAM
Intel® Core™ i5-7200U CPU @ 2.50GHz × 4
Mesa Intel® HD Graphics 620 (KBL GT2)
Ubuntu 22.04.1 LTS
GNOME 42.4
Wayland Windowing System

I’ve used OM 6.2 without this problem for a long time on this same machine but on Ubuntu 20.04 LTS. This only has begun after upgrading to 22.04 LTS.

OM log is bellow - but I don’t know if it registered the last fails (the date of the log file is Oct. 18th…)

openmusic-log (105.6 KB)

I may add that OM 7.1 is showing up a message just after initialization (OM 6.2 was not, by the way):

I hope you can figure out what is going on! Thanks for your attention!
Paulo

Dear Paulo,

reading your log, it seems that you are running LispWorks 7.1.2 which is really strange and i doubt that this is happening!

I suggest to clean up your install first, ie remove ALL OpenMusic installations on your machine, and install the latest version. It appears that you have conflicting OM’s runing.
All prior to version 7.0 are based on LW 7.x
Starting from OM version 7.x, OpenMusic uses LispWorks 8.x
It could be probably this mix up that is resulting all these crashes.

Please keep me informed.

Best
K

Dear Karim

Many thanks for the fast reply. I will try a complete removal and reinstalling OM 7.1 aftwards to see what happens. I suppose then that 7.1 installation will get correct version of LispWorks, right?

In the meantime, I would like to send some more information, just in case…

I tried to run OM 7.1 from the terminal, so I could better monitor what was happening (not that I would be able to understand it, but…)

Firts of all, even before crashing again, I noticed the following messages on terminal:

Warning: (defun g304592) being redefined in listener (previously in /media/priosfilho/dados/tudo/composicao/bujokas-russia-2022/trio-russia/elements/008f-polyphonic-pitch-rules.omp).
Warning: G-domain : nil, level 16: invalid source position for vertical gradient
Warning: G-domain : nil, level 16: invalid source position for vertical gradient
Warning: G-domain : nil, level 16: invalid source position for vertical gradient
Warning: G-domain : nil, level 16: invalid source position for vertical gradientGtk-Message: 23:07:38.428: Failed to load module "canberra-gtk-module"
Gtk-Message: 23:07:38.430: Failed to load module "canberra-gtk-module"
Gtk-Message: 23:08:44.110: Failed to load module "canberra-gtk-module"
Gtk-Message: 23:08:44.112: Failed to load module "canberra-gtk-module"

Warning: G-domain : nil, level 16: invalid source position for vertical gradientGtk-Message: 23:11:14.569: Failed to load module "canberra-gtk-module"

Nonetheless, this session didn’t crash - I quit to search about this canberra-thing, instead.

So when I re-launched OM 7.1 from Terminal, a new session soon led to a crash and that were the messages on terminal:

Gtk-Message: 23:25:10.114: Failed to load module "canberra-gtk-module"
Gtk-Message: 23:25:10.116: Failed to load module "canberra-gtk-module"
Warning: (defun g304600) being redefined in listener (previously in /media/priosfilho/dados/tudo/composicao/bujokas-russia-2022/trio-russia/elements/008f-polyphonic-pitch-rules.omp).
Warning: (defun g304592) being redefined in listener (previously in /media/priosfilho/dados/tudo/composicao/bujokas-russia-2022/trio-russia/elements/008f-polyphonic-pitch-rules.omp).X-IO-ERROR on ":0 {Lispworks}" : Fatal IO error 11 ("Resource temporarily unavailable") Xlib: request 10 length 24 would exceed buffer size.
Xlib: request 40 length 16 would exceed buffer size.


!!!!!Wrote error log to /home/priosfilho/logs/LispWorks/openmusic-log at 2022/10/21 23:35:13
Xlib: request 14 length 8 would exceed buffer size.
Xlib: request 40 length 16 would exceed buffer size.

Error: Segmentation violation(11) [code 0] at 7F5FDD8F86A1
        Foreign code offset #x71 from symbol "XTranslateCoordinates"
        module "/lib/x86_64-linux-gnu/libX11.so.6" [ #x7F5FDD8B2000 ]
rax            0 ; rbx            0 ; rcx 7F5FDF2FFA6F ; rdx            0
rsp 7F5FD628DE50 ; rbp            0 ; rdi 7F5FD00476F0 ; rsi 7F5FD628DE60
r8            35 ; r9  7F5FD628BBA6 ; r10            0 ; r11          293
r12          824 ; r13      2C02076 ; r14 7F5FD00476F0 ; r15 7F5FD628DEF0
  1 (continue) Remove display-callback from #<patchpanel  426026CD63>
  2 (abort) Return to event loop.
  3 Destroy interface "^008f-polyphonic-pitch-rules" (of type editorwindow)

Type :b for backtrace or :c <option number> to proceed.
Type :bug-form "<subject>" for a bug report template or :? for other options.

Maybe it’s relevant to note that this new session’s caberra-module message came a considerable time before the crash…

I hope this information help figure out the problem! Anyway, I will try the complete removal and reinstall tomorrow and let you know!

Thanks again,
Paulo

Ok thanks for reporting.
Now it appears clearly that it is a gtk2 problem.
LW8 depends on gtk2 and wants to use libcanberra-gtk-module which appears either not installed on your Ubuntu by default or “wrongly” installed.
However, i will try today to install your version of Ubuntu so i can see better. on the 21.20 it’s working OK without crashes. With all dependencies installed.

Best
K

Dear Paulo,

Ok I’ve just tested OM 7.1 on a freshly installed Ubuntu 22.04 LTS on my VM. No problem using it. No crashes.

As stated above, it might be that your libcanberra-gtk-module is not installed correctly.
Since from all OM’s dependencies you have just to install (always on a freshly installed Ubuntu 22.04) libportmidi0 and libcanberra-gtk-module. So i suggest you re-install libcanberra-gtk-module.

For info, on a Debian based install, dependencies are:
libsndfile1, libportmidi0, libsamplerate0, libgtk2.0-0, gtk2-engines-murrine, libcanberra-gtk-module, fontconfig, mime-support, desktop-file-utils, libcurl4

Please keep me notified.

Best
K