< Back to IRCAM Forum

OM crashes systematically on Ubuntu 21.10

I have OM 6.20 running on Ubuntu 20.10 and it crashes systematically regardless of the operation.
I tried previous OM versions and experienced the same problem.

Is there any fix?

Please send more information about your problem:
logs, system and cpu specifications, etc. will be most helpful, since this problem was never reported yet on ubuntu.

Hi Karim.
I saw a similar post (though not exact):OM 6.17 Linux crashes after few minutes of edit - #3 by fredvoisin.

Running on a Dell with i7, 8gb ram.
I see new users can’t upload files here, where should I send the OM log?


You can send it to me in a private message.
However, before then, can you tell me:

  1. did you install OM using the .deb package?
    If yes, did you install the required dependencies?

  2. Which exact Ubuntu you installed?

  3. which window manager are you using? (gnome, kde, etc…)


I see only ubuntu version 21.10 and not 20.10 on the download url of Ubuntu, that’s is why i am asking.
Therefore, i will install it and test it to see if it is an incompatibility.
Tried already on 20.04 LTS and OM works there…

Will be back for more info, awaitng your log.


Really sorry, my mistake:
I’m running Ubuntu 21.10, 64bit. Windowing system is Wayland.
I installed the .deb package from the OM website, I didn’t install manually anything. I assumed Gdebi installed the dependencies.
It seems I’m not allowed to attach files in the forum, please let me know how to send you the log.

OM runs it just stops responding every time.

Thanks again!

No trouble,

I will proceed to install this latest release then (21.10) and will tell you how it goes with OM.
Will be back soon.

Ps: You can send it to karim haddad @ ircamfr

However, maybe you can try this:

  1. Remove om package
  2. Be sure you are in the sudo group
  3. sudo dpkg -i openmusic_6.20-1_amd64.deb
  4. Now this will tell you if the install succeeds or fails
    if your package manager did the right work so ignore. It could be that it didn’t find the correct versions of the dependencies. But give me some time to test, and will be back with further feedback.


Moreover, ok for wayland, but what is your type of desktop you use, plasma, gnome, etc??
If you don’t know so probably you are on Gnome (default desktop of Ubuntu)

Hi Karim,
Yes, it’s gnome.
I’m attaching the log.

openmusic-log (875.6 KB)

Thanks and looking forward to your feedback…

Dear amichai

Everything went smoothly. So, i suspect as I said before, that your install was not succesfull using Gdebi. So first of all you should remove openmusic:

  1. Open a terminal
  2. type sudo dpkg -r remove openmusic

This will remove the installation of openmusic.

Now let us install the dependencies as follows:
(always using the terminal - you can copy paste the following:)
sudo apt-get install libportmidi0 libcanberra-gtk-module

Now go with the terminal to opennusic .deb installer (openmusic_6.20-1_amd64.deb)
Using ls
If you don’t have it on your disk download it WITHOUT automatic installation, we must install it using dpkg.

To install in terminal:

sudo dpkg -i openmusic_6.20-1_amd64.dpkg

And now you are done. openmusic should run.

If you run into trouble please feel free to report.


Thanks a lot Karim,
I followed the instructions (and verifyed that OM was unistalled before re-installing) but I still experience the same situation. Om runs then Ubuntu says OM is not responding and I have to quit and start again, sometimes after a few minutes and sometimes after a few seconds…
Any other ideas on how to fix this?

Ok this is very weird. Did you install other applications, and if yes did you run into trouble… Will check this again.

A screenshot, and a system log will be also helpful.

It’s my main computer so it runs applications regularly (musescore, open office, reaper, zoom, etc.), I didn’t experience any problems, however it could be something in the Ubuntu version since about a year ago I had a different version (both Ubuntu and OM) and never had any problems.
I’m attaching a screen shot of the message and CPU during the “freezing”, I don’t know if that’s normal that CPUs reach 100% when an app freezes, just in case it’s useful. When I quit CPUs go back to normal. And syslog, it’s 8mb so I had to zip it.
syslog.zip (973.6 KB)

Thanks for your help, I hope there’s a solution.

Ok, i see. so the problem is not coming from OM since you are able to launch it. I was completely mislead by your report. Can you send me zipped your workspace. I see here some patches which apparently you downloaded somewhere. It might be that your workspace is corrupted. This way i can do something about it.
If you are not able to send it here (due to the forum limitations), send it to my email.


Workspace.zip (805.1 KB)
Here it is, indeed I downloaded some patches, some were zipped from mac.
Sorry my explanation of the problem wasn’t clear…
Thanks a lot Karim!

Dear Amichail,

There seems some mixup in your Workspace folder. There are patches outside the elements folder. Besides there is also a folder containing patches named test. This is not so good. It could be one of the reasons of this crash:

Here is a cleaned up version of the workspace with the alien patches and folder alongside.
Workspace_cleaned.zip (809.8 KB)

Beside that, you should disable the tooltips from the preferences (gemneral menu). This is also known to cause such crashes on Linux. (still needs to be fixed).

Tell me if this works for you.


Hi Karim,
Unfortunately I still have the same situation.
I used the cleaned workspace (deleted the test thing), the preferences were like on the screen shot you sent. Today I managed to work for about 12min but then again the same thing.
I thought it might be the synth (before, I worked without running it) but this time it was running and still…
Any more ideas?

Hi amichai,
If you had OM running for 12 min, and had problem, this means (it’s a guess) that the problem is elsewhere. Since you are mentioning midi, can you:

  1. say when the problem occurred exactly?
  2. send a screenshot of the midi preferences as so (by clicking on the ‘Ports setup’ button:

    Now if your input device is pointing at the same as the output, then, here is the problem. Midi doesn’t like this at all.

Now if it is not the case, please provide more description of your problem and midi setup.