< Back to IRCAM Forum

Issue with OM 6.16 on linux and micro intervals

for some strange reason, after installing OM on a ubuntu 18.0.4 and going over the tutorials as first baby steps I found a strange behavior regarding micro intervals: the pitchwheel message required to play those intervals, as explained in tutorial 10, will not operate (I’m using qsynth). after a few tries, the only workaround I found is to activate the auto-microtone-bend in the preferences.
Does anyone knows this behavior and does the auto-microtone-bend option could effect any other behaviors (I assume, since it is not a default option)?
Many thanks in advance,

Dear Dan,

Thank you for reporting this. In fact, something has changed in the 6.16 version of pitchbend messages (Anders ?).
I will look this up and come with a solution ASAP!


Dear Dan,

Ok this issue has been fixed. I reverted the code concerning it, since the new code, once “pitchwheeled” gave “funny” transpositions!
So you should:

  1. quit OM
  2. put the .lisp file i am attaching here in:
    (for mac users it would be in:
    /Applications/OM 6.16.app/Contents/init)
  3. start OM

By the way it is funny no one reported this!

Best and take care all of you!

pitchbend_fix260320.lisp (337 Bytes)