< Back to IRCAM Forum

Error on loading a sound


I’m getting the attached error message when trying to load a sound in a soundfile object.

Is there something I might be doing wrong?



Hi Jimmie,
This seems an omaudiolib issue. (omaudiolib is a shared library inside OM).
Can you specify the following things:

  1. What machine and OS you are using
  2. Which OM dmg did you install (and version).
  3. and what kind of soundfile you are trying to load (aiff, wav, etc.)


Machine: MacBook Pro 2021 (M1 Pro), Monterey 12.2.1

app/dmg: OM-7.0-macOS-M1-13-03-2022

Soundfile type: .aiff

I also installed the last fix (to be put in the init folder): fix210322.lisp

Dear Jimmie,

Sorry for the late reply. I have been testing this issue thoroughly. I happen to have the same setup of yours and i didn’t encounter any problem of this kind. Can you please be more specific on these details:

  1. the exact aiff file (sample, channels, etc…)
  2. Do you have somewhere else installed OM/om# or omaudiolib?


Hi Karim,
Thank you for the attentive follow-up.

  1. aiff file: stereo, 44,1kHz, 16 bits
  2. Yes, I have multiple OM versions on the hard drive, although I always run only one at once (was that your question?)

Yes indeed.

Maybe please do retrieve all OM versions former to the latest 7.0 version (130322 release) from your /Application folder, since the shared libraries might conflict with the latest release. All other former release are not 100% compatible on M1.

Once removed (you can archive them elsewhere), restart your computer and try again. I believe your problem will be solved and please do report back in either case.


Hi Karim,
Tried what you suggested (removed all versions and workspaces, I actually just compressed them and then trash the originals), makes no difference, still the same error.
Is it possible that the faulty component is duplicated elsewhere in the system?

No, I don’t believe that it is the case unless you compiled it yourself. However you can check by doing a search of these libraries:
and specially
libsndfile.dylib. THis last one might have been installed and loaded by another app (?).

Did you happen to install either MacPorts or Homebrew packages?

Searching the two libraries didn’t return any result. As for Homebrew, I think it was installed on my previous computer, but it’s not installed on the one I’m currently using. But I also configured the new computer by using the automated import function on Apple, some some parts of Homebrew could have been imported as well?

this is possible. You might want to look in /opt/local/lib or /usr/local/lib depending the installation,

just type cmd+f and type libsndfile (without the extension) this will give you the results of all libsndfile.dylib installed. And if there is an /opt/ folder, and you did a timemachine import from a previous Macintel, it could be the reason of all this error.


Here is what the libsndfile search returns (see attached)



But this is not really helpfull, it only means you have a lot of this library around your HD. But it would be helpfull if we know WHERE they are located. A dynamic lib such as this, if it is local, system wide installed, or disabled is not the same thing. So i suspect you have some intel x64 lib and application still installed on your system and it conflicts with the one in OM.
By the way apparently you are not the only one to have this issue:

So please be patient, so we can figure it out.


Thanks Karim,

Many of those are in folders related to various apps, and do not seem to be shared at large in the system, but I could not tell… I attached here what I find in the user/local/lib path you suggested me to look at, is it more relevant?

Bonsoir Karim,
Aucun problème pour moi pour OM 7 sur mon IMac qui tourne sous Big Sur. Et félicitations, il me semble que cette version est nettement plus rapide qu’avant.
En revanche, alors que j’ai jamais eu de problème d’installation sur mes PC, je n’ai pas réussi à installer OM 7 avec le PC sous windows 10. Je joins les deux messages d’erreurs concernant cette installation. A noter que la dernière installation d’OM-Sharp a échoué aussi. Mais là, a priori, c’est lié à l’installateur.

No this has nothing to do. Maybe also look in /usr/lib ?

Bonsoir Didier

omaudiolib.dll ne doit pas du tout etre dans le dossier /WINDOWS/system32/
l’as-tu mise la manuellement?
Tous les .dll qui viennent avec OM7 doivent rester la ou ils sont installe, c-a-d dans le dossier “OpenMusic 7.0” comme ceci:

Donc il faut enlever tous les dll que tu as deplacer et re-installer OM.


Here is what I find in /user/lib:

Bonjour Karim,
Merci pour ta réponse rapide. Sinon, non, je n’ai pas installé OM 7 manuellement, l’installation a été faite avec le programme d’installation (j’ai fait une vidéo avec l’affichage de la progression de l’installation si cela t’intéresse). En fait, alors que je pensais que OM n’était pas installé, il l’a été en partie et le message “Something wrong calling functions from omaudiolib:” s’affiche dès l’ouverture d’OM. Puis, quand je fais OK, la fenêtre s’ouvre sur le choix ou création du workspace. Et peu importe le choix, création ou existant, le message "Error : Foreign function… to unresolved external function “openAudioManager” s’affiche et quand je valide avec OK, OM s’interrompt.

Did you install omsharp?

Ce qui est tres etonnant, c’est le omaudiolib dans le repertoire WINDOWS/system32. L’installeur de OM ne l’installe pas la. Est-ce que vous avez installe un autre logiciel avec omaudiolib comme omsharp ?
et est-ce que les .dll sont toujours dans le dossier OM comme dans mon screenshot precedent?