< Back to IRCAM Forum

OSCar & M1 Compatibility

Hi,

I wanted to know if you have some information about the compatibility of OSCar and M1’s computer.
I’m running with a MBP with M1Pro ship, and Monterey. Max & spat5 works perfectly but I have some issues with OSCar. The plug don’t receive OSC stuff (the green light supposed to confirm data reception is not turning on, and everything is correct about ports and network stuff), but actually there is no problem with the send section, from the daw to the other world.

And when I try to set the Max’s UDP tester in the same port than an instance of OSCar, Max’s console says that:
Capture d’écran 2022-04-04 à 16.13.13

Thanks for the help :slight_smile:

Have a nice day,
Orian

(PS: never had such issues before I changed my computer!)

Hi Orian,

In theory, OSCar is compatible with M1.
If the plugin loads in your DAW, you’re probably fine.

In any case, the error here has nothing to do with M1; I think the error speaks for itself : for some reason, port 4001 is not available. Either it is used by some other application, or it was used by something that crashed and did not properly free the port afterwards. In most situations, restarting the computer solves this kind of issue.
I hope this will also solve the issue with OSCar not receiving data.

Hope this helps,
T.

Hi Thibaut,

Thanks for the quick answer. Actually, it’s not an issue with the 4001, it says the same with every port I try to put OSCar’s UDP receive section on. I’m used to work with the plug, works well with my old 2014 MBP, and i already restarted several times my M1, and tried to reinstall the plug.
It’s also not a problem from my patch send section, works fine internally (with another UDP receiver in another patch), it’s just OSCar… And as I said, the weird thing is that OSCar’s send section works as well.

i also tried to restart my internet box, didn’t worked either :slight_smile:

I work in Live 11.1 by the way, and I noticed that the plug makes it crash sometimes!

Thanks,
Orian

Hi Orian,

  1. In the OSCar window, the input port number appears in green if the port is properly bound, and in red otherwise. Is 4001 green in your case ?
  2. The corresponding green LED blinks only when OSCar receives messages that are compliant with its current settings (as specified in oscar.xml).
    Could it be that you are sending messages that do not match the oscar.xml settings ?
    Can you provide more info ?
  3. Have you maybe tried with a different DAW ? AU / VST3 ? Is the behavior similar ?
  4. I believe that, in latest mac OS, each application must have specific “entitlements” to use the network layer (UDP). Is it possible that your Ableton Live (or Max?) is blocked by the OS ? Maybe something to check in your OS security settings ?

Sorry I cannot be more specific. Just trying to guess where the problem comes from.

Best,
T.

Hi,
Same issue for me.
If I use Oscar with repair and Panoramix on my mbpro 2015 all is fine,
if I try on my M1 I can send message to Panoramix but receive nothing from it.
On Reaper for Oscar the input port is green, but the green led never blinks when I move in Panoramix.
Does someone arrived to do that with a M1? do you know where Mac is blocking the message?
Thanks
Félix

Do you use OSCar in AU?

If so, try the VST3 version instead, it works better,

No problem with Ableton Live

I have a Mac mini M1 and no problem with OSCar. Some friends of mine, using Reaper, told me there’s some issues with the last versions.

in general when you loose a OSC connection, reboot !

Hoping it helps

Best,

Jerome

Hi Jérome,

Thanks for your answer.
I made different tests, and finaly with the M1 or with the mbp 2015 i have the same issue!
I am a sound engeneer, not a max programmer, i know how to use the softwares, but i probably do something wrong.
On the both computers it is very easy to write an automation for X and Y, and panoramix play it (with its cpu very high when it moves, but the audio cpu is at 8%, and the mac below 10%, so i don’t understand what is this cpu…), i can do it with reaper or with live.
But when i move a track in space in panoramix, i see it sends on port 4001, if i use a software like Protokol, it monitors all the movements on this port, so it works, but on Oscar there is nothing, the green led don’t blink and nothing arrive on my tracks when i record.
Probably something i do wrong, same issue on 2 differents computers, with last versions of Live 11 and reaper, so frustrating.
I prepare a theater show in HOA and wfs, and would like to record all positions easily to be able to recall them easily for the show…
If anybody has a solution for the newbie i am.
Thanks, best regards
Félix

Sorry me again…

I analysed the output mesaages and there where not as the input, so in panoramix in edit mode you can choose between “azim/elev/dist” or “x/y/z” for the output signal.
Nice, now it works easily on my mpb 2015, both on reaper and live.
But, on the m1 it is impossible to choose port 4001 for Oscar, i can write it, it is green, but as soon as i move a track on the viewer in panoramix, in oscar the value of the input port changes alone, it becomes 4000 or 0! and i do nothing to this value, like if there was a security somewhere to avoid oscar to listen to this port!
Any issues?
The 2 computers have the same config, and one is working well, and the other refuses…

Thanks, best regards
Félix

Hello Félix,

Hum, it’s not quite clear what is happening here.
Could you maybe make a screen recording, so that I can try to understand the workflow ?
Also please indicate the version of OSCar (AU / VST ? version number ?), Panoramix, etc. Which ports are you trying to use on the different tools ?

Best regards,
T.

Hi,
Thanks for your interest in my pb.
Here is a screenshot of what happens.
When I play in reaper the automation I wrote, no pb, there is the green led in Oscar, Panoramix receive, and the position (red circle) move.
But if I put the send action in Panoramix and try to move the position of the red circle (on the screenshot), the port on Oscar becomes 4000 automatically (green circle), and yet I had put 4001 before.
As soon as Oscar receive something, it changes the input port from 4001 to 4000, and so nothing is received…
Hope it is clear, if I do the same with my mbp 2015, all works fine!
I tried the 2 last versions of reaper, Oscar in vst3 and AU (version 1.2.4), and my version of Panoramix is the last 1.6.0
As all works on an older Mac, I think it is M1 or Monterey the pb but I don’t know how to solve it…!?
Thanks for your ideas

Best regards
Felix

Hum… I have never seen anything similar. So, that’s really weird, and I’m not sure what to do either.

Could you maybe try with the (new) version attached ? (note that this is just a test version; not an official release)

Also, can you try to make a video recording of your screen ? (you can do that easily with Quicktime)
Maybe it would give us a hint.

Best,
T.

https://filesender.renater.fr/?s=download&token=cb125f45-b50d-4b55-a267-be09f987a504

Hello,
I tried your new version, it does as the old one.
But I found a way to to it work, instead of port 4001, I use port 4000 or port 3999 for example, and then it works! (my knowledge in use of this port is absolutely nothing)
Here the video I made of this (sorry a little heavy but if not you couldn’t see anything.
Thanks

avec la video, finalement compressée