< Back to IRCAM Forum

OpenMusic 7.0 released

OpenMusic 7.0 has been released.

This version is compatible for these operating systems:

MacOS: 64bits - ARM and Intel processors
(separate installers, please install the one matching your processor)

WINDOWS: 32 bits

LINUX: 64 bits RPM and DEB packages, tar-ball

NEW FEATURES

  • OM image built with LispWorks 8.0
  • Send And Receive in/out
  • gkant, experimental rhythm quantifier based on omquantify managing grace-notes.

IMPROVEMENTS

  • reducetree recursive version.
  • Comments now have an editor. Shorcuts:
    -‘c’ opens a comment window
    -‘o’ if comment is selected, opens the window comment for editing

FIXES

  • SOUND object reloads new sound after sound not found message
  • mxml export debugging
  • patch mode in score is really saved
  • omloop copies input creation/deletion are refreshed
  • Fix extent issue of chordseqs multiseq output

Enjoy
K

1 Like

hello karim,

would it be possible to set the font color?, because this is difficult to read for my eyes. is there some way of defining it despite it’s not an end-user choice? I’m on an intel with Mojave with dark theme.
Screenshot 2022-03-15 at 13.19.56

Screenshot 2022-03-15 at 13.09.07
edit: I can confirm this only happens on dark theme only.
thanks in advance,
perti

Dear Perti,

Yes i know this issue. LW8 now supports dark theme. I will see what i can do to correct this. Meanwhile, please use normal theme if possible, and will be soon back with a fix.
Sorry for this inconvenience.
Best
K

thank you Karim for the super fast reply. meanwhile I was able to force om7 into light mode with this command:
defaults write fr.ircam.repmus.openmusic NSRequiresAquaSystemAppearance -bool YES
thanks again!

1 Like

Thank you very much, Perti

Dear Petri,

Thanx a lot! Your trick is great. For the moment i think Dark theme users on MacOS should use it, until i find a practical way to adapt OM’s look for this theme. Unfortunately it is not automatic.

Best
K

Hi,

Thank you for this new release. I can confirm it is faster on Linux Fedotra 32 and on OsX El Capitan.
I apologize in advance if this is not the place, but I have a little strange behaviour on El Capitan (not on Linux): at opening the software a window advising of loading a library remains opened long. I can not close it, I must wait for the closure. It is not the usual advice window, and the loading library is not always the same. I enclose a screenshot. Is it possible to resolve that?

Thank you in advance, ciao

Fabio

Dear Fabio,

Very strange. Can you list me the libraries present in the workspace path?
It could be related to non compiled libraries. To see if the library is compiled:

  1. open the source folder of the library and look for files ending with .xfasl.

Best
K

(sorry for multiple messages, I have tried to answer also from my computer mail software…)

Hi Karim,

Thank you for fast reply. I have really many libraries in my
OM/Libraries folder, but in loading the workspace only some of them are
signed for pre-loading: Alea, my own library, OMChroma, OMPrisma, OM-
pm2, OM-Spat, OM-SuperVP, OM2Csound, om4csound.

The advices since now are relative to Alea, Situation (required by
mine), OM2Csound.

Is it possible the main problem is about the libraries required by
mine one? (FDSDB__XXth_CT)

Thanks

Fabio

P.S.
OM2Csound and my library have no .xfasl files. How can I compile them?

Hi Karim,

Thank you for fast reply. I have really many libraries in my
OM/Libraries folder, but in loading the workspace only some of them are
signed for preloading: Alea, my own library, OMChroma, OMPrisma, OM-
pm2, OM-Spat, OM-SuperVP, OM2Csound, om4csound.

The advices since now are relative to Alea, Situation (required by
mine), OM2Csound.

Is it possibile the main problem is about the libraries required by
mine one? (FDSDB__XXth_CT)

Thanks

Fabio

Dear Fabio,

I will look into it. As i understood from you this concerns ONLY these libraries:
Alea, Situation OM2Csound.

PS: Please can you open a new thread for this issue?

Dear Fabio,

Just tested with he following autoload libraries:
FDSDB__XXth_CT, Alea, Situation OM2Csound it loaded smoothly without any problem.
(I tested this mac Intel Om version running under Catalina).

I don’t really understand why this “hanging” messages appear. I hope it is not your HD that is somehow “tired” or a file access issue?

Best
K

Hi Karim -

Thank you for the new release!

I’m seeing an issue loading OM-SuperVP. I’ve pointed at the external but when attempting to load the library I get the message:

“Error while loading the library OM-SuperVP. Package nil not found.”

I also see the following in the listener:
OM > “Loading library OM-SuperVP - v. 2.13”
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/package.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/general.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/normalize.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/analysis.64xfasl" …"
OM > “WARNING: File /Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/processing.64xfasl is older than the LISP source file. File /Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/processing.lisp will be loaded instead.”
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/synthesis.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/channels.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/formants.64xfasl" …"
OM > “FASL error: #P”/Users/graham/OM/Libraries/OM-SuperVP 2.13/sources/om-preferences.64xfasl" …"
OM > "

Thanks Karim.

All the best,

Graham

Dear Graham,

I suspect you have copied your libraries from an Intel mac machine to your new M1 machine. The compiled library source files *.xrfasl, where compiled under the Intel compiler, that’s where the problem is.

FIX: Download the latest libraries from our repository here:

And try again.

Now if i am wrong about my diagnostic, please feed us with more precise info about, your Os, Machine, etc.

Best
K

Thanks Karim -

I’m still seeing the “Error while loading the library OM-SuperVP. Package nil not found.” message.

I downloaded all the latest libraries from GitHub, re-downloaded OM 7.0 (Intel Mac), re-dowloaded super-vp and PM-2 command line tools, installed them under Applications, updated config.

I’m not seeing the 64xfasl messages in console, but it still doesn’t load the om-supervp library.

I’m seeing the same error in OM6.20 btw.

Any ideas? Thanks Karim.

Config here:
iMac Pro Intel. MacOS 12.3 Monterey.

Hi,

Just dropping by to share a high-resolution version of OpenMusic’s icon:

All the best,
António

2 Likes

Great Antonio,
Thanx for the artwork!

K

1 Like

here’s my own Icon…

AnyConv.com__om-icon.icns (156,8 Ko)

Hi Jérôme,

A couple of years ago I started working on a smooth-surface icon based on the original drawing, but ended up settling with the pixel-art version I shared above and never finished it. Here:

In order to convert it to an icon you only need to change the extension of the file (directly in the file name), and macOS handles the file-format conversion automatically.

All the best,
António

3 Likes