< Back to IRCAM Forum

Om2csound basic problem

Hi all,

I’ve decided to wade into om2csound/chroma, but I’ve run into one basic problem out of the gate. The instructions say to install csound in /usr/local/bin, but that doesn’t seem to be possible. I’m running OM 6.16 and recently installed Catalina (Mac OSX).

If anyone can kindly explain this to me, I’d be very grateful.


sorry, problem solved. :slight_smile:

Dear Michal,

There are two problems here:

  1. Instructions asking you to install csound in /usr/local/bin. This has been solved in the coming new release of the om2csound library. The library once loaded, will query the the path to your installed csound binary wherever it is.
  2. The Catalina problem. Like most of the softwares, they can be (or not !) installed here and there.

As you seem to have solved the problem, it is good. Just to know, what “flavor” ie, installer you used to install csound ? a dmg or did you install it with Homebrew/Macports ?

Keep safe


Dear Karim,

I used the dmg version.

WRT the /usr/local/bin issue, - for some reason the contents of the directory were different depending on what I used to search for it. Eventually it was there, right out of the install.

I did come up with some new problems, though.

  1. (which probably has a lot to do with 2 and 3) I don’t know anything about CSound, and even with the manual, it’s going to take me a good while before I’m just randomly plugging in values.

  2. Whenever I synthesize a chord seq (ex. 4 from the tutorial), the sound file comes out about a whole step sharp. Strangely enough, when I export the file and listen to it in the QT player, (and analyze it in SPEAR to double-check), it plays back correctly. I think I remember reaing about this problem on the forum somewhere before, but now I can’t find it.

  3. I tried to use OM-chroma (also from a dmg), and I get the error message attached below. Don’t know if this is a 32/64 bit issue, a Catalina issue, or something else entirely.

Many thanks and best wishes,

PS: If you know of a really good, explain-like-I’m-in-preschool guide to CSound as it pertains to OM, I’d very much appreciate that too. So far I am totally confused, even with the manual. (On edit: I just found a tutorial I can understand, so at least there’s that :slight_smile: )

Dear Michal,

Are you sure that you have the latest version of OMChroma (5.1)? The function “printdate” is defined in the file “utils.lisp” (in the OMChroma 5.1 / sources / chroma folder), it is an old function which has always worked. When I try add-1 in OMChroma, it works without problems.
If you need to access this function from a patch (it is not an essential one, it just nicely prints the current date in the csound score), you need to type “cr::printdate”. Perhaps you can try it in a patch, just to see if you get the same message.
Let us know, please.

Dear Marco, thanks a lot, I updated to 5.1 and it fixed the problem. In the meantime, my learning curve with csound has been pretty high (I discovered cabbage, and also some texts by Richard Boulanger), so I’m very excited to learn about all of these new functionalities.


Hello Michal,
If you read some French (or if you master automatic translation tools!) you can also have a look ad Jean-Michel Darremont’s OM-Csound tutorials:

1 Like

Dear Michal,

For a starter, you can go there:

Now what about the incorrect pitch sound output?
Can you please specify if this happens while playing audio in OM and/or MIDI ?


Dear Karim:

Thank you for the link. :slight_smile: The problem for me is the user manuals only start to make sense after I’ve spent a lot of time doing trial and error. So for instance I understand, in theory, that you can make additional p-fields, but not why they don’t seem to work when I make a .sco with them. (I have this problem with OM as well but after 4 years or so, it’s getting better). I found a lot of youtube videos that bridged the gap, though.

Anyway, about the audio, the issue seems to be that audio files come out sharp, in comparison to the MIDI, which I’m almost certain is correct. The really strange part is that when I played them back outside of OM, they were normal (I didn’t know that was even possible). I fiddled with the sample rate and bit rate, but that doesn’t seem to help.

Cher Jean, merci pour ces links, ils sont tres utiles. L’ecriture est proche de mon niveau de comprehension aussi, j’ai apprisait beaucoup en lisant les instructions pour omtristan…

Thanks again and all the best,

Just a few more questions:

First, the playback problem was indeed caused by having the wrong sampling rate.

Second: I downloaded OMPrisma (v.2.35) and every single patch gives me this error message:

So, am I missing something obvious, or did I download the wrong version again, or is it a Catalina problem?


Deear Michal.

Hmm this seems an error with omprisma library. Can you send the patch ?

Sorry, I’m not quite sure what you’d like me to send. I’ll take a guess and hope it’s this. 1-overview.omp (7.0 KB).

But actually I get the same message in every patch.

Cheers :slight_smile:

No i meant the patch in your screenshot. Anyhow, it is in onprisma help files and called panning. Got it!
THe problem seems as i suspected coming from prisma:

rtmidi: ALSA Raw MIDI module enabled
:: error: e[mUnable to find opcode entry for ‘limit’ with matching argument types:
:: e[mFound: a limit iic
:: adelaytime limit idelaytime …
:: Line: 94
:: from file /home/karim/Downloads/sofia.wrk/out-files/my_synt.orc (1)
:: Parsing failed due to syntax errors
:: Stopping on parser failuree[m
:: e[mcannot compile orchestrae[m
:: e[mend of score. overall amps: 0
:: 1 errors in performance
:: a beep!

Meaning that there’s a non standard Csound opcode used here: limit . It must be a user defined opcode and should be defined here in this synthesis.
Please do contact the author of the library in order to fix this.


Thanks, I will try to contact him and let him know. Do you think that one problem would cause the whole library to malfunction?


there’s a real problem with this patch.

I can open OMPrisma… everything looks ok but your patch asks me that :

image twice
and all then box are dead :

the same patch, coming from tutorials, works !

Hoping it helps…


OK, this is turning into a real head-scratcher… the patch I sent is directly from the tutorial. So actually I don’t understand anything now. :smiley:

No Michal,

It is not the whole library that is malfunctioning. It is simply a bug in the .orc generated by the example. I advise you if you need to learn csound, just use the om2csound for a start. Then you can start exploring the amazing omChroma library. As for prisma, i am afraid that you will encounter more than a bug.

Now concerning the Jerome issue, he just opened the patch without the needed linked patches (yes sometimes patches refer to others.). The patch is linked to another one to be found in the help tutorials of the same library.


Hi Karim,

That’s how I’m doing it. I am having an easier time with Chroma than OM2Csound (because Chroma doesn’t require me to really know much about CSound), but I am using both. I wanted to use Prism simply to turn the output of Chroma into nice stereo files. The more elaborate stuff isn’t really for me. There is a bit of spatialization in OMChroma, but it seems to be at the i-rate rather than k.

So, either way, I will make do without prisma, but what confuses me is that for me, none of it works (the link I provided is directly from the downloaded helpfiles, I didn’t modify it in any way). OK, back to learning CSound for me,


Dear K,

You gave me an idea for a question.

About patches and sub-patches, is there a way to transform a patch in a patch (green patches) into a sub-patch (red patches) in order to merge everything ? I use do that with copy/paste… there must be a better method.

THX in advance,



Just slide your green patch into another one. Select your patch, type ‘a’
(TIP: when inside a patch type ‘h’ for help)