< Back to IRCAM Forum

OM 7.3 rc

Dear OM users,

You will find here installers for Mac, windows and linux of OM version 7.3 release candidate, meaning all thsi is for testing purposes:

Please if you have issues, please report here.

Best to you all
K

1 Like

So, it loads the workspace now, and I can create and work on patches.

I launched the app (after copying it to my applications folder), and created a brand new workspace in my User/OM folder as I would usually do.

However: when I try to save the workspace this error appears.

When I press OK,this shows up in the listener console:

OM > “Saving workspace…”
OM > "ERROR: No applicable methods for #<standard-generic-function |OpenMusic|::get-elements 80E0BF39DC> with args (nil)

Call to om-lisp::om-error-handler
Call to invoke-debugger
Call to error
Call to cerror
Call to (method no-applicable-method (t))
Call to clos::apply-no-applicable-method
Call to |OpenMusic|::ws-save-globals
Call to |OpenMusic|::save-ws-contents
Call to (subfunction 1 (method |OpenMusic|::editor-save (|OpenMusic|::workspaceeditor)))
Call to om-lisp::om-work-function
Call to mp::process-sg-function
"

It appears that I still cannot access the preferences, like with previous 7.* releases, when I open preferences OM freezes and stops responding.

Let me know if there is any way I can help (system logs somehow, etc), I’ll be glad to.

Lorenzo

  1. Where are you saving your workspace?
    Can you post the path?
  2. And did you disable the dropbox extension?
    It looks to me it is a problem of permission,

Definitely looks like a permissions problem… But there is nothing I can see from system settings->security & privacy. And yes, Dropbox extension is still deactivated, app is not running, and out of the login items.

I’m saving to Users/“User”/OM/Workspaces/
I also tried having my workspace in Users/“User”/OM/ (where the Libraries folder is) but it nothing changes.
I’m logged in as the administrator of the computer, so there should be no problem on that side concerning permissions…

I just noticed another thing: patches save to the Workspace (I see them in finder) despite workspace not saving, but they do not appear in OM 7.3 when I (force) quit and reload the same workspace. The preferences.lisp file also appears to be rather emply (dunno if it’s normal). It only contains two lines:

;7.03
(in-package :om)

Hi All,

If useful: I have tried to install OpenMusic-7.3-2.x86_64.rpm on Fedora 32, but I receive an error:

Problema: conflicting requests

  • nothing provides libinstpatch-1.0.so.2()(64bit) needed by OpenMusic-7.3-2.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

My command was: sudo dnf install ‘/home/fabio/Scaricati/IRCAM/OM_7.3_rc/OpenMusic-7.3-2.x86_64.rpm’

Is my Fedora version too much old?

Many thanks in advance, ciao

Fabio

P.S.: I have installed libinstpacjk, but the problem persists.

Dear Fabio,

Yes there is a problem with the packaging. I am rebuilding it so it could work on older Fedoras. Will let you know when it is ready.

Best
K

No this is not normal.
Will check it out again. It is perfectly working on Sonoma.

BEst
K

Dear Fabio,

The release was upodated and tested on fedora 32. So now this will work without problem (i hope).

Best
K

Can you please check the following:
-What other extensions you have?
-can you delete the folder here: /Users/youraccount/Library/Preferences/OpenMusic/
and restart.

Plenty of extensions, actually… Are there categories that are likely to interfere?
The only active in the “finder extensions” now is GoogleDrive. There are others in other categories though. I can attach a screenshot actually:

There are also login items and many apps allowed in the background. Do you suspect anything there?

I’ll try to delete that folder and restart, I’ll let you know in minutes.

Lorenzo

After deleting the preferences folder and rebooting, still the same behaviour… As soon as I try opening the preferences, OM freezes.

What i suspect is your Google drive extension. Looks like it messes things up. I am not sure since i don’t have anymore Ventura. I am on Sonora. And i don’t know how did you get this extension.

furthermore, if you are using icloud storage system this may be also a reason to make OM fail.

If OM runs in safe mode, this means there is an incompatibility with these issues

best
K

Hm, I understand… I will try disabling GoogleDrive and iCloud and try again.
The finder extensions for GoogleDrive are automatically installed with the Drive app, I’m guessing?
In order to operate it from the finder instead of using the website.

I’ll try disabling anyway and report back.