< Back to IRCAM Forum

Yin~ don't work and request activation

Dear all,
ON the Max Sound Box all external works good except the pitch tracking external Yin~
keeps on showing the modal when trying to open it ( see image below )
Is that normal ?
how could i use this external properly ?
If you have any idea please do not hesitate.

I’m on Max 8.1.10 MacBook Pro 2020 TB MacOS 10.15.7 Catalina 16G RAM

All the Best

Hello,

Are you sure you only have the latest version available on the forum in your search path?

Best,

Greg

I have the latest MaxSoundBox on my Packages folder and this folder is on the search path.
I found an other yin~external in that path Macintosh HD :/Users/omarkarray/Documents/Max 8/Packages/ircam-omax_y-Max6.1/externals/yin~.mxo so delete it and empty the trash.
Now on my max console i have this message : yin~ (pitch analysis), version 1/2021 (15)

So no i pass without the activaton modal. But Yin~ on the help file dose not seems to process.
see in the attachement the short video demonstrating the issue that i have. here i have also rooted the signal coming from sfplay~ to the dac~
Signal is present and passing to Yin~ but no signal at all in the output …

Hi,

have you tried other sound files?
Is the help patch the one in the same package as the external?
What architecture and version of max is yin~ running on?

Glad that finding the right version of the external has already solved your activation problem.

Bonjour Greg,
Tried diffenrent sound files no one of them works.
I’m on Max 8.1.11 64-bit MacOS 10.15.7
The help file is on the same packakge as the external.

I have made a new video attachement implementing a basic operation:
a cycle~ wave with 220Hz passing to the yin~ external. the yin~ pitch out hangs on 19.87 Hz value.
next to it i have the max external retune~ used also for pitch traking same signal passing and this external is working.
N.B: my computer is brand new so those are new installations on my old mac i was using yin~ correctly and it have more accuracy than the retune~ external specially for old phonographic instrumental recordings ( for a research project ).
i do not kow if this external is open source may be i could build it on my computer with xCode ?

Your help is much appretiated.
And all the best.
Omar Karray

Hi Omar,

Yin~ is not open-source but maintained by the Ircam ISMM team.
I don’t have currently a 10.15 mac to do the test.
Maybe @borghesi you have an idea ?

Looking forward

Hi Omar,

I’ve Big Sur 11.6, And yin~ works well… I have tried with a electric bass recording and the f(0) is ok !

image

Hoping it helps…

Jerome

hi all, same for me on OSX 11.6 and Max 8.1/8.2, yin~ works well.
Best
Riccardo

Hello All,
@beller thank you for helping me sort it out an maybe try with BigSur upgrading my system it could be this the issue !!
Yin~ is an exceptional object that I use from years now thank you all of you for the great work at IRCAM.

( I’m noticing also some problems on my Mac with old patch’s that work well before …)

All the Best
Omar

Hi @omar,

Please let us know how your problem was resolved.
It could happen to someone else…
And good luck with your updates.

Greg

Bonjour @beller ,
first of all i have upgraded to MacOSX 11.5.2,
then i have made a clean install of Max Resetting Max with a clean install – Cycling '74 Support , having sampling rate of 48 kHz :partying_face: Yin~ is back to work. and my other patches too.
I also do not have the problems that i have before with Catalina regarding USB-C Hub that was presenting little disconnections with the USB audio interfaces. ( i think the problem is related to Catalina on the Macbook pro 2021 but not sure ). anyhow the max/msp clean install seems to be a good solution if the max app is behaving weird.
bonne journée a vous.
et merci encore pour votre aide et suivie.

1 Like

Hi @omar,

glad you can track the pitch again.
From what I remember (and I’m not part of Apple’s referral program), using the Apple-branded USB-C Hub may solve some connection issues …

All the best