< Back to IRCAM Forum

"Undefined Operator in Form"

Dear Modalys users and team —

I’ve been running ModaLisp 3.5.1.b4 successfully for a year but came across a new error after months of no use. In any new Modalys file I create, evaluating a simple function such as (new) consistently produces:

Error: Undefined operator NEW in form (NEW)

whereas the same function evaluates successfully as long as it’s within a previously created .mos or .lisp file. This same error occurs for setq and setf functions and generally everything I need to start building a Modalys script. I’ve tried copying functions directly from old .mos files into new ones, but regardless of where it’s copied from or the file extension, new files always produce these errors.

I installed a fresh ModaLisp 3.5.1.rc4 but still this strange behavior persists. I’m in Mojave 10.14.6.

Could anyone shed some light on this?

Thanks in advance —

For those interested —

A solution was found by inserting the LISP in-package macro at the top of a newly-written .mos or .lisp file and evaluating in ModaLisp:

(in-package ::mlys)

Seems to be working now…

1 Like

Hi Louis,

thank you for sharing…


1 Like