< Back to IRCAM Forum

Unclear why "CHANT not found!"


When trying to evaluate functions from the OM-Chant library, I get the error: “CHANT not found!!”. The library and all of its components are loaded correctly, it seems, but CHANT doesn’t show up in my externals, so I guess that’s were the problem lies.

Is there some solution to this problem?

Running on:
MacOS Catalina 10.15.4
OM 6.16
OM-Chant 3

Thanks in advance for your help!

1 Like

Hi Eveline,

There’s a few things you can check:

  • Is Chant correctly installed in your library?
    => If you have the latest version of teh library (3.0), it should be in /OM-Chant/resources/bin/macos/chant

If it is, you can select the “Print system output” optiuon in OM Preferenfces (tab: “Audio”) and report here what is printed in the OM Listener.
I would expect somethig like:

OM-Chant :: ==========================
OM-Chant :: ==========================
OM-Chant :: Running CHANT with [SOME SDIF FILE]
OM-Chant :: Number of channels= 1
:: "[PATH_TO_OM-CHANT]/OM-Chant/resources/bin/macos/chant" -i"[SOME_SDIF_FILE].sdif" -o"[SOME_OUT_FILE].wav" -sw16 -n-0.0 -v


Dear Eveline,

The chant binary is to be foun din the library’s omchant folder here:
OMChant 3.0/resources/bin/macos
You just have to open OM’s preferences panel, and choose the Externals tab and there you are.


Dear Jean,

Thank you for your quick answer!
Chant is in /OM-Chant/resources/bin/macos/chant like it should be.
This is printed in my Listener:

OM > "Loading library OM-Chant_3.0"

 OM-CHANT 3.0 (c) IRCAM 2010-2019
 Control of CHANT in OpenMusic

Dear K,

Thank you for your reply!
The problem is, there is no Chant showing up in my Externals tab, so I can’t choose the correct directory. This is the current state of my Externals:

I think it is normal that OM’s external preference don’t show the Chant exe: since v3.0 (of OM-Chant) the executable is embedded and at a fixed location within the library: in principle there is no need for you to set it anywhere specifically.
I’d be interested to see more of your command line: the one you reported is the one that prints when you load the library. Can you copy the one that is print when you try to synthesize a sound (after CHANT SYNTHESIS ... )?

Hello Jean,

My problem is solved! These are the steps I took:

  • Yesterday evening, I deleted a duplicate OM-Chant library that didn’t contain Chant in the resources/bin/macos/.
  • Just now, I renamed my folder from OM-Chant_3.0 to OM-Chant.
    Now everything works like it should.

For completeness, here is the log you requested (from the chant tutorial 04b-fof-sub-audio)
OM-Chant :: ==========================
OM-Chant :: Running CHANT with /Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.sdif
OM-Chant :: Number of channels= 1
:: “/Users/evelinevervliet/OM/Libraries/OM-Chant/resources/bin/macos/chant” -i"/Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.sdif" -o"/Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.wav" -sw24 -n-0.0 -v
:: Chant create temporary file: /Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.wav.sf.tmp
:: Chant Synthesis begin.
:: Chant Synthesis end.
:: Chant normalize output file. Level = 0.000000 dB.
:: maximum amplitude peak found = 3.955669, scaling factor to apply = 0.252802
:: Chant writing audio file (/Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.wav) with Info:
:: Sample Rate : 44100
:: Total Frames : 176401
:: Total Channels : 1
:: Output Format : Microsoft WAV format Signed 24 bit
:: Chant delete temporary file.
:: Chant Process finished.
Removing files:
Loading sound file info: ‘/Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.wav’
/Users/evelinevervliet/Desktop/Untitled/out-files/ch_04b-fof-sub-audio.wav Loaded…
OM => #<sound 4020002F0B>

It isn’t clear to me what actually was the problem. But anyway, I’m happy my problem is solved.

Thank you for your support!


ok, I think this one ran just fine and had no problem finding Chant.

Apparently you had two versions of OM-Chant.

The name of OM library folders matters; more precisely, the name before the first white-space character is considered as the “name” of the library. It must match with the name of the .lisp file in it (in this case, OM-Chant.lisp). So, you can indeed rename it to OM-Chant, OM-Chant 3.0, … but not to OM-Chant_3.0.

Good you found a way to get it working anyway :slight_smile: