< Back to IRCAM Forum

SuperVP Kernel Error

I’m having problems with AudioSculpt v.3.3.8 (with OSX 10.11.6). Whenever I try to perform a Source Filter Synthesis, I get an error message saying:

The kernel “SuperVP” reported an error.

I would like to re-install AudioSculpt v.3.3.8 to see if this will fix the problem.

Is there somewhere at IRCAM ForumNet where I can re-download my 3.8.8 version of AudioSculpt to achieve this?


Do you always have this supervp error, or is it only when you try to use the Source Filter Synthesis ?
May be you should reset the settings to the “Factory Settings” : look at the bottom of the Source Filter panel and change the settings popup menu to “Factory Settings”, then retry to perform your synthesis. In case you have a configuration conflict that may help.

If you want to download again a previous AudioSculpt version you can look in the Archives section here:

Best regards,

Thank you for your helpful reply Charles.

This supervp error only occurs when using ‘Source Filter Synthesis’. ‘Generalized Cross Synthesis’ works fine.

When I try to download the version of AudioSculpt I paid for originally, I get a message saying:

The requested download is not purchased yet. Please add to cart and proceed to checkout.  

I’ll try again with factory settings.

Hello, Audiosculptors,

I wonder why this simple example does not work. I’m using a hand-made parameter file for a formant filter (formant-3, attached below) with a simple noise. When I run SuperVP from the command line, I get the error shown in the attached figure (where you can also see the command line used). I’m using AS 3.4.6, with Mac OS X 10.13.6 and a lot of memory, but other students of mine who tried to do this with other OS X systems had the same error. How to solve it, please?
Thank you very much in advance.



Hi Marco,

the most likely error would be in the formant parameter file, can you share that ?


Marco, I think your earlier attachment of the parameter file didn’t work because the forum site didn’t recognize it as allowed content. I think it should work if you rename the file to formant-3.txt (I think I read somewhere that the attachment filtering is based on the extension)

Thank you very much for the quick replies, Axel and Frederic, and sorry for forgetting the extension. Here’s the formant-3.txt file again. Hope the system will accept it now.


formant-3.txt (480 Bytes)

I couln’t manage to reproduce the error using AS 3.4.6 and MacOS 10.12.6, and had no luck either directly calling supervp from a terminal. I generated a 10s file at 48kHz containing white noise, but maybe there’s something in the input file you are using that triggers the bug. Could you attach it here so that I can check this?


From the supervp source code, it seems that the _M_fill_insert error can happen when the formant filter parameter file is invalid, but the file you posted is fine. I did get this error once after cut-and-pasting from your file to one generated by AS, but when I opened the file again it looked fine, and when I ran the supervp command again it worked. I only got this once, and despite trying many things (including gatekeeper/quarantine options and re-installing AS in several different places), I couldn’t find a consistent way to reproduce the problem. I guess the problem might be related to tightened restrictions related to gatekeeper, so maybe a workaround would be to move the parameter file outside of /Applications

Does this happen for all of your students, every time? Did you have the same kind of problem with other filter types? Did you manage to use a different custom formant filter this way?

From the screenshot, I imagine that you first add a formant filter with the default “Soprano A” preset, process treatments through AudioSculpt, then use the bottom pane to edit the last command to use the hand-made file as a parameter to -Ffof-noex. But maybe you edit the AS-generated file instead, or replace it. Could you tell me the steps and tools you use? Details might be important: for instance editing with TextEdit is different from some other tools, and copying using the Finder is very different from doing it through the command line. Also, replacing an existing file is different from creating a new one (especially because of the hidden attributes used by the Mac “security” system)

I’m out of ideas, so I’ll give up trying to reproduce the bug for now

Dear Frédéric,

Thank you so much for trying to solve this apparently curious problem. I did also spend some time in the last days to try to figure out what and why this happens.first of all, this is how we proceed:
a. we compute a formant-filtered sound (white noise)
b. we edit the Temp/formant-1 file generated by AudioSculpt and name it differently (normally, if a mistake is done in changing this file, we get a normal error message), most of my students use TextEdit for this.
c. we cut/paste the last command line in the last window of AS, change only the name of the parameter file, and recompute the processing (here too, if there is a mistake in the syntax, a comprehensible error message appears).

On my computer (OS X 10.13.6), during my last tests, I simplified the formant-3.txt file in order to leave only one formant, and edited it with TextWrangler, and, to my surprise, it WORKED!! I then added the second line, computed, and it worked, until I got back to the original parameter file (which worked), and has been working since…:frowning:

One a student’s computer, running OS X 10.14.2, however, this technique did not work and he consistently gets the _M_fill error (he edits the parameter file with TextEdit). So, I believe that your supposition is right, it seems something related to the (dirty, hidden) security processes OS X does behind your shoulder.

As you kindly asked for the simple “noise” sound we were using, I attach it below (compressed), but I do not think that this is the problem.

I continue to experiment, if I can reproduce the problem again.

Thank you again.


noise10test.aif.zip (897 KB)

I did a few tests with TextWrangler and the way it renames and saves files is quite different from what TextEdit does, though I don’t know what these differences mean in terms of iterations with gatekeeper and other “security features”.
I don’t have access to 10.14 (I’m stuck on 10.12), but from what I’ve read the security restrictions have indeed been tightened. One thing I noticed is that the whole /Application/AudioSculpt 3.4.6 folder is marked as “quarantined”, not just the application. Even on 10.12, that means that the “AudioSculpt 3.4.6.app” is copied before AudioSculpt is launched from that copy. Maybe 10.14 applies something similar to the whole folder, including “Temp”, and there’s some confusion when editing a file residing in that folder from an outside application.
If so, maybe copying the formant-1 file somewhere in the user’s home (Desktop would do) then editing and using that copy would avoid the problem. You should also be able to skip the copying step and just use the parameter file itself. This doesn’t even require typing: erase the original file name from the command line and drag/drop the file from the Finder into the AudioSculpt bottom pane.

Dear Frédéric,

It seems that the problem was, indeed, TextEdit. Editing the parameter file with TextWrangler solved the problem, whether the file was in the /Applications/AudioSculpt folder, or on the Desktop. Thank you very much for leading us into the right direction, although this OS X behaviour is quite… scary for the future.