< Back to IRCAM Forum

Supervp for max and sample rate

Dear all,

I’ve noticed that many objects from the supervp for max collection (at least supervp.play~, supervp.scrub~ and supervp.sfplay~) present a bug when loading a soundfile with a different sample rate as the actual one, since they don’t seem to compensate this always at first loading (supervp.play~ does that “from time to time”, supervp.scrub~ never compensate the sample rate at startup). This can be corrected after loading by switching the “transpose on/off” setting to “off” and then back to “on”, however I did not find a way to automate this so that the speed is correct when loading the patch.

On top of that, supervp.play~ and supervp.scrub~ throw out the following message in the console:
“svp buffer sample rate change: 0.000000 -> 0.000000”

Is there a reliable way to avoid this?

Best

Alexis