< Back to IRCAM Forum

Somax2 2.6

i just installed the Somax2 - 2.6 2024-03-18 version, following the instructions *

(Copy the extracted Somax2 folder into the Packages folder in your Max folder (by default, this is "~/Documents/Max 8/Packages")

I have mac chip M1 with the latest Max version, trying to write somax objects in a new Max patch doesn’t find anything.

(somax2: No such object)

I also tried writing ‘somax2’ in the terminal and received this message

(zsh: command not found: Somax2)

Thank you so much for the support!

Hi cristiano,

thanks for opening a thread here.

The behaviour you are encountering is normal, since it seems you tried to create a [somax2] object in Max, but this is not the way Somax2 should be used.

First, to check if the package has been correctly installed in your Max environment, please open Max (no need to open an actual patch, just the application) and go to the “Extras” menu, in the top bar.
Here, you should be able to see the “somax2.overview” together with other packages you might have eventually already installed:

I highly encourage you to start from this general patch to navigate through tutorials and different use cases of the Somax2 package.
You will also find ready-to-play template patches in the “Performance Strategies” tab of the “somax2.overview”:

When you will be ready to create your own patches, please keep in mind that to create Somax2 objects in Max you should address them correctly (creating an object called [somax2] as you were trying to do won’t work and it will result in an error, since the object doesn’t exist in the package).
You can find the list of all the available objects, as well as their help files and documentation in the “Help Center” tab of the “somax2.overview”:

So, if for instance you want to initialize a Somax2 player you should create an object called [somax.player] etc.

Last thing, the terminal in Somax2 is only used as a monitoring of the different messages that the applications gives you (the same messages are actually mirrored in the Max Console), so you cannot interact with Somax2 by typing there. All your interaction will be in the Max patches.

Beside the “somax2.overview” patcher, in the package you downloaded there’s also a “Somax2 User’s Guide.pdf” that can help you navigate through the application.

Please let us know if this helps you and if you could use the package correctly.


Hi Marco,
thank you for your help!

There’s nothing in Max’s extras, I had already checked. In addition to downloading the package and copying it into the ‘packages’ folder, I also downloaded and copied the zip folders ‘externals’ and ‘somax2.6’ where patches like somax2.overview are located. When trying to open this patch, I can’t interact with it; it seems like Max doesn’t recognize the somax2 package properly.

Best, C.

Here’s a screenshot of my Max packages folder.

inside Somax2-master folder

Trying to open the patch somax2.overview from the folder…

Hi cristiano,

thanks for your reply.

It seems that you are not actually installing Somax2, but you’re rather in an in-between situation.

There are actually two ways of installing Somax2, the “easy” way which consists of using the dmg (extracting it and locating in the Packages folder - but you are not extracting it), and the “programmer” way, which means downloading the python code and setting up a python environment on your machine (not recommended in this case).

You Somax2-master folder is not the “easy” installation way, but it’s the GitHub folder that contains also the python code, and therefore should be compiled for it to run (it’s the “programmer” installation, you can see you have also a python subfolder here). Let’s forget about this.

On the other hand, the Somax-2.6.0.dmg is the application installer we are referring to and we want to fix.

Let’s try this:

  • close Max (cmd+Q, or quit the application, it should be restarted for installation to take place)
  • move the Somax-2.6.0.dmg folder on your desktop (no need for this to be in the Packages folder)
  • delete the Somax2-master folder
  • Open the dmg and copy the whole Somax-2.6.0 folder that appears now into your Packages folder (this folder is the one to install, already containing all the subfolders/documents you might need, and do not change its name):

  • Restart Max (close the application and open it again)
  • Now check for Extras menu, and see if you have any messages in the Max Console
  • At this point, in your Packages folder there should be only the Somax-2.6.0 folder, with all the subfolders as in the image I’m attaching above. You can see there’s no python folder, and all the right subfolders are there.

I hope this solves your issue


Perfect, all sorted! Thank you so much for your help!

1 Like

Dear Marco,
when I start the overview Max patch, it gives me this series of errors in the message box, maybe issues with the externals?

Thank you for your patience.