< Back to IRCAM Forum

Simplifying meshes (for finite elements)

Dear all —

Hope everybody is doing well this summer.

Thanks for the lovely updates and tutorials recently. I’m putting them to work and hoping to move beyond some recurring issues. Today, I’m placing a few relevant files into a single Google Drive directory here for anyone who might be able to shed some light on the issues described below.

If someone could lend some insight, I’m building off of the recent Ircam forum tutorial and video tutorials demonstrating how to load mesh .obj files using the awesome new lua controller. Currently, I’m able to view the mesh and object generated in Modalys after successfully importing a mesh .obj file that I’ve worked a lot on, but Max typically crashes the moment I begin adding access points and connections.

The included mesh file has been reworked a number of ways:

  1. in SketchUp: original geometry realized, exported as .obj
  2. in Blender: parent objects ungrouped and remeshed to 0.1 meters, again exported as .obj
  3. in Instant Meshes: again remeshed to quad with no apparent gaps or hidden geometry, exported as .obj

This third and final .obj is what appears in the folder linked above and which has finally been successful on import using Modalys’ “read-from-file.”

In Medit, the geometry also agrees with what I have in Blender — no apparent holes, all faces visible, and the model does not take as long to load as the larger files I’ve generated from other, less successful remesh attempts I’ve made. To be sure, I’ve also tried using a number of “clean up” extensions in SketchUp, but so far nothing has been more efficient than the Blender / Instant Meshes routine described above.

I do get some interesting error messages in the Max console that I don’t fully understand, and I’ve also included a crash log in this folder as well. Again, crashing only begins when I add any sort of access points or controllers in Modalys. I can still obtain a mesh with block points visible in Medit. The problem really seems to begin once I add in details at line 52 in loadobject.v01.lua.

Thanks in advance to anyone who might be able to help me understand where these errors and other console messages are coming from, or for anyone who could interpret the crash log.

Many thanks and very best wishes —

1 Like

Dear Louis,

Thanks for your thorough message.
I will definitely take a look!

It seems Modalys is unable to compute the modes for this particular mesh.
Possible reasons: 1) its very large size 2) its complexity (lots of vertices) 3) Its geometrical irregularity (many degenerated* quads…)

I would say 3) is probably the main reason, and it is often the case when we work from a software that is not designed for mechanics (and rather for visual).

Could you by any chance come up with a simplified mesh, with regular quads throughout?

Also be aware that you have so far is not a solid, but rather a hollow object. If you want a actual solid object, you will have to deal with solid elements (i.e. hexahedra). But Blender and the such do not deal with solid elements (Catia or SolidWorks do…)

(*) degenerated: a quad squeezed into a triangle…

1 Like

Thank you @piechaud

Are you exclusively using Catia or SolidWorks? Others on the forum have spoken about successful imports from Blender, Instant Meshes, and Meshlab, but I’m unsure of the right combination of steps using their mesh repair tools. I haven’t been able to achieve a simplified mesh apart from the many steps already taken.

Can you tell me what specific steps you take, in whatever software, that accomplishes this for you?

In theory, the steps I’ve taken have eliminated any degenerated quads and other geometric flaws. There is some chatter online about mesh export problems. For example, all my geometry is of simple forms: walls with sharp edges on all sides. If I understand correctly, Blender (and possibly SketchUp) export models with some kind of hidden edge smoothing, rendering the edges as smooth or beveled without the user’s awareness. I’ve made efforts to correct for any hidden features like this and preserve my model’s sharp edges, but it doesn’t seem to work. Instant Meshes has a remesh function that seems to return sharp edges (at least in the viewport that seems to be the case; I’m not entirely sure if the math checks out…)

As it stands, I’ve attempted to re-mesh this wall and clean up its geometry in Blender, SketchUp, Instant Meshes, and MeshLab.

Thanks in advance. I’d really value your expert suggestions here.

Best —


Have you made some progress on this topic? I haven’t managed to successfully make any external finite elements model, even a simple one, to run properly with mlys so far. It would be nice if some easy-to-use and free converter/generator were available…

1 Like

Hi — I’m hoping for the same! Unfortunately, I haven’t solved this yet but have just had to cut corners by simplifying geometry. I’d love to enter into a more in-depth discussion about these issues… Maybe some of us on the forum can pool out experiences as a start…