SDIF Library

Hello everyone,

I’ve tried to build the SDIF Library from sources. I’ve downloaded the zip file of the latest version from SourceForge, SDIF-3.11.4-src.zip. I unzipped it into my home folder (/Users/antonioflorenca) and entered the following set of instructions in Terminal:

mv SDIF-3.11.4-src SDIF-3.11.4
cd SDIF-3.11.4
./configure --prefix=pwd --enable-shared=no --enable-pthreads=no
make
make install

Everything goes ok (with a few warnings), as far as I can see, until “make install” (I’ve also tried “sudo make install”), for which I get:

Making install in sdif
test -z “/Users/antonioflorenca/SDIF-3.11.4/lib” || …/./install-sh -c -d “/Users/antonioflorenca/SDIF-3.11.4/lib”
/bin/sh …/libtool --mode=install /usr/bin/install -c ‘libsdif.la’ ‘/Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.la’
libtool: install: /usr/bin/install -c .libs/libsdif.lai /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.la
libtool: install: /usr/bin/install -c .libs/libsdif.a /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
libtool: install: chmod 644 /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
libtool: install: ranlib /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
make[2]: Nothing to be done for install-data-am'. Making install in include make[2]: Nothing to be done forinstall-exec-am’.
test -z “/Users/antonioflorenca/SDIF-3.11.4/include” || …/./install-sh -c -d “/Users/antonioflorenca/SDIF-3.11.4/include”
/usr/bin/install -c -m 644 ‘sdif.h’ ‘/Users/antonioflorenca/SDIF-3.11.4/include/sdif.h’
install: sdif.h and /Users/antonioflorenca/SDIF-3.11.4/include/sdif.h are the same file
/usr/bin/install -c -m 644 ‘sdif_version.h’ ‘/Users/antonioflorenca/SDIF-3.11.4/include/sdif_version.h’
install: sdif_version.h and /Users/antonioflorenca/SDIF-3.11.4/include/sdif_version.h are the same file
make[2]: *** [install-sdifincHEADERS] Error 64
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

Any idea what went wrong here and how I can fix it, if at all? Any help on this would be greatly appreciated.
I’ve attached a rtf file with all the output from Terminal running the whole of the instruction-set listed above.

All the best,
António

install-SDIF-3.11.4.rtf (38.3 KB)

You should not use --prefix=pwd during configuration

The prefix is the directory where you will install the result. And pwd is the directory where you are currently bulding. If these are the same then you would install inplace which will not work
leading to the error

install: sdif.h and /Users/antonioflorenca/SDIF-3.11.4/include/sdif.h are the same file

Just use any other directory (where you can write) as prefix.

Best
Axel