< Back to IRCAM Forum

Pulsemaker starting with a rest?


Trying pulsemaker with (4 4) (8 8) (4 (-1 1 1 1)) gives me an unexpected result: the rest is missing in the 1st bar of the voice. Is this a bug or I’m missing something? (pic attached).

om 6.15
ubuntu 19.04Screenshot_2019-12-07_05-23-18

Hi rc.

The result you get is the expected one, the first ‘4’ in the n-pulses being how many pulses you want to divide the first measure into, the second - the list of '(-1 1 1 1) - specifies the second measaure.

Try exchanging the first “4” with e.g. “3” to see the effect in the first measure.

If you want two measures of (4 8) time, with the first pulse being a rest, pass '((-1 1 1 1)(-1 1 1 1)) to the n-pulses input.


Dear rc

Good you seem to have tracked some incoherency here. THe default parameter for
n-pulses is confusing. It should not be '(4(1 1 1 1)) .
the rule here is that n-pulses is a list made of either integers or a simple list of proportions.
So when you use (4 (-1 1 1 1)) the first 4 is for “4 beats” and the second list is for the second measure. I know this is confusing. Should update the method and the documentation.

THis screenshot i hope is self explanatory: