< Back to IRCAM Forum

Problem finding omaudiolib

Windows 11
I just installed OM 7.0
I get immediately te message " Something wrong calling functions from omaudiolib:
After I click OK, and launch OM, it won’t work , I get the message:
ERROR: Foreign function
juce… OPenaudiomanager trying to call to unresolved external functio “openAudioManager”
Thanks for the help

Dear Daniel,

Sorry about that. Here is the page, (the download button is on the right):

You just remove the omaudiolib.dll in from the folder and replace it by this one.


Thank Karim
Works perfectly now!

1 Like

Currently having this issue with OM 7.4 on windows 11. The posted link isn’t working, and redownloading/renaming file is no longer working as a fix.

Sorry riohoule,

Sorry but i don’t understand your problem. Can yo be more explicit?

Thank you

I am still with OM 7.1 , Windows 11, and have still no issue about that

1 Like

Dear Riohoule,

One think to take into consideration, is that the 7.4 version is in 64bit. So it could be that once you launch OM the app still points at the old binaries (32bit). So you need to uninstall the old version.


hi same problem, dont know how to uninstall the old version since I only have installed the7.4 version


What is exactly the “problem”. Can you post the error dialog?

Hello K,

Apologies for the late response, I’ll be a bit clearer. After installing and opening OM 7.4, I am immediately met with the error message described in danielschellmus’s post, “Something wrong calling functions from omaudiolib:
/Windows/system32/omaudiolib.dll.” Clicking OK takes me to the usual workspace selection menu, but upon selecting my intended workspace, I get an ERROR: Foreign Function message, exactly like the original post, followed by the program immediately closing.
I followed the fix described in this post and similar posts, including downloading omaudiolib.dll from Github and replacing the one in the original installation, I tried this with the x32 and x64 bit version, but with no luck.

Trying the fix you provided in this message, I noticed that OM 7.4 is automatically installed in the folder C:\Program Files, while previous versions of OM, (OM 7.1, 7.2) were installed in C:\Program Files (x86) and these versions were functional. I don’t know if this would have anything to do with the issue, but I did still try uninstalling previous versions, this did not fix the error.
Thanks for the reply,

Hi Rio,

It is normal that 7.4 installs in the C:\Program Files and not in C:\Program Files (x86) since it is an x64 bit and all its dlls are in 64bit.

Now OM 7.4 must use the 64bit dlls and not the 32bit ones. Apparently you have omaudiolib.dll installed in /Windows/system32/omaudiolib.dll and OM 7.4 is pointing to it whereas the error message. You should remove all OM related dlls from there (carefully of course). The dlls provided by OM distributions should not be moved elsewhere, since this will mess up things.


OM 7.4.exe Message 16_04_2024 20_59_53
This is one of the problems I get. The other is about 32bit audiolib problem since I have 64bit Intel CPU

OM 7.4.exe Message 16_04_2024 21_26_11

Hi gonzalezsanderjuanpa,

Can you just verify if there are no omaudiolib.dll in your /WINDOWS/system32/ folder, because i think this is causing the problem.


There is no omaudiolib.dll in my WINDOWS/System32/ folder. I don`t know how to solve these two errors since they won´t even let me open Openmusic software.
Kind regards

Hello Karim,

I have exactly the same problem as gonzalezsanderjuanpa on Win 10 64bit. With a new install of OpenMusic 7.4 I get the exact same error messages.

7.4 Installed on Linux without a problem, but the windows version is not starting or even letting me create a workspace. Running the Installer as Admin made no difference.

However, the 32bit version installs and runs fine on my Win 10 64bit system.

Regards from Berlin,

Dear All,

Thank you for your feedback.
Unfortunately for the moment don’t have a window 10 available, but soon will test it ASAP.

On Windomws 11 ot seems running.

A suggestion:

  1. uninstall OM 7.4 (with the uninstaller which should be found in your Program Files directory or inside OpenMusic 7.4 directory)
  2. Install OM 7.3
  3. reboot and launch 7.3


Dear all,
Indeed i have tested OM 7.4 and there is a problem loading some Dlls. It is strange though it is working on my computer, maybe because i have LispWorks installed, but this is no solution.

I will debug this. I am again very sorry for all this trouble.

Meanwhile you can use OM 7.3 which is working.

Best regards.
PS: Will keep you informed.

Dear All,

I hope this is bringing good news.
I have recompiled the omaudiolib.dll and apparently it works now (tested it on a clean windows 10 install).
here is what you do:

  1. download the compiled omaudiolib.dll from here:
    openmusic/OPENMUSIC/resources/lib/win64/omaudiolib.dll at master · openmusic-project/openmusic · GitHub
    (the download button is up on the right side)

  2. go in your C:/Program Files/OpenMusic 7.4 folder

  3. delete the old omaudiolib.dll

  4. copy the new one

this should make it work (I hope).

Please report any problems.
And sorry for this inconvinience.