< Back to IRCAM Forum

Playing with OM7 and VCV Rack 2

Hopefully this is not an inappropriate post, my apologies if it is. Feel free to delete it if necessary.

Anyway, it’s a little demo of using OM to “play” a patch in VCV Rack. See the YT notes for details. I’ve also tested it with a maquette of similar patches. It works fine but doesn’t loop play correctly (plays once through, repeats the first patch in the maquette then stops).

OM7 on a Mac Mini M1. Many thanks to Karim and all developers of OM, OSC, and VCV Rack ! :slight_smile:

1 Like

Dear Dave,

Thank you for your great example. And yes just tested the Maquette/loop issue. It is apparently an old bug and not related neither to osc or your lovely setup above. Will try to fix this. Thank you a lot for pointing this out.

Best
K

1 Like

Dear Dave,

I fixed the maquette loop play mode. Here is the patch (to be put in the init folder of OM’s distrib:
maquette_loop_fix.lisp (1.5 KB)

It will be included in the next release.

Thank you a lot for reporting this.

Best
K

Hi Karim ! Thanks for the fix, it works nicely now. Unfortunately the patch seems to have altered something in my settings that I’m finding difficult to repair. Text in the Listener is set to white now, which made it invisible when I first started OM. I reset its background so I can read it now, but how do I reset the text to its original black color ? Also, note that the opening workspace selection box is now “off” - the selection text is missing (see the picture).

Screen Shot 2022-06-12 at 6.17.54 AM

Screen Shot 2022-06-12 at 6.21.26 AM

Dear Dave,

Yes, this the “dark mode effect” that messes display in OM. I have fixed this in the upcoming version forcing OM not to use the darkmode even if it is selected . So just for the time being, please do use the apple’s aqua default mode.

Someone also posted a “trick” to disabled it for OM. will try to find the command a post it.

Sorry for this inconvenience.

Best
K

About the dark mode issue here is the post concerning the terminal command to undo darkmode for OM only (was buried in a long thread):

Mar 15

thank you Karim for the super fast reply. meanwhile I was able to force om7 into light mode with this command:
defaults write fr.ircam.repmus.openmusic NSRequiresAquaSystemAppearance -bool YES
thanks again!

Once again, my thanks to the maestro. :slight_smile: The terminal command fixed the issue, appearance is much nicer now.

Another little experiment.

2 Likes

Awesome!