OMLily: A Bit of Minor Debugging

Hi,

If you’ve followed the instructions for using LilyPond as a command-line tool, as prescribed and needed by Karim Haddad’s omlily library, here:

http://lilypond.org/macos-x.html

You’ll find, and probably did find, that omlily won’t recognize it. Here’s the fix:

Go to the sources sub-folder of omlily, and open the lilypond-preferences.lisp file in a text editor. Where you read (at line 37):

(t (list :lilypond-path (pathname "/usr/local/bin/lilypond")))))

Replace it with:

(t (list :lilypond-path (pathname "~/bin/lilypond")))))

That’s it, you’re set.

All the best,
António

Dear Antonio,

Thanx for pointing out this. Butit is supposed to work if you are on mac. Are you using a mac and which version are you running. On my macos Sierra this works perfectly well without this tweak. So maybe they have changed something. I would be very curious to see this…

The path indicated by /usr/local/bin/lilypond should concern other oses than linux or mac…

Best
Karim

Hi Karim,

I’m on macOS Mojave 10.14.5. The issue, as far as I can see, is that the LilyPond page instructs users to create the bin folder in their Home folder, and then place the lilypond executable there. I actually agree more with the path you set by default, it’s a far better place to put the executable in, but that’s not what they instruct users to do.

All the best,
António

Ok, i agree.
But did you test it without the modification? It worked for me.
Because if you look to the code in question there a “switches” directing to OS used which calls :
(pathname (find-lilypond))

either way if it is on linux or on mac.
So maybe the trouble is elsewhere. However, i don’t have mojave. It could be something changed somewhere.
Just let me know if without your suggested correction the code works.
It is not to be pedantic, but because i am releasing a new version of the library and want to be as much user friendly as it can get !
:smile:
Thanx a lot by the way Any suggestion and/or bug correction is always welcome

Best
K

Hi Karim,

I had to change the code to make it work, beforehand omlily didn’t recognise the executable. I tested it without the code-change again this morning like you suggested, still the same issue as expected. I might be wrong, but the reason it works for you in macOS High Sierra is perhaps quite simple, you placed the lilypond executable in “/usr/local/bin/”.

The only alternative I can see for Mac users is to instruct them to place the lilypond executable in “/usr/local/bin/”, perhaps through a Readme text file in the main omlily folder. I actually think that it would be a better alternative than the one offered by the LilyPond page.

It would be nice to hear from other Mac users, just to see if this is a Mojave-specific issue or even just a quirk of my system for whatever reason…

All the best,
António

Dear Antonio,
Well this very strange. Just checked up where lilypond lies on my mac installation. It is in the ~/bin folder. Now why it is so. Because the lilypond installer on linux, (it’s a script, and i am a linux user mainly), installs the binary either localy in ~/bin or in /usr/local/bin indeed.
Now, ther is an issue here, with the preferences. In the external tab, lilypond should point to the lilypond script (for mac) where it is installed. By evaluating om-os variable you should see :mac or :linux depending your platform. You should have the correct answer, or else something is really wrong. However, no big issue, i’ll see into that.

Many thanx.
K
PS: Will soon anounce ASAP the release of version 3 of the library.