< Back to IRCAM Forum

OMAudioLib.dll problem

Windows 11
A week ago, I downlaoded OM 7.0 and had a problem with OMAudioLib.dll
Karim Haaddad answered giving this reference



This file is binary. show original

I could fix replacing OMAudioLib.dll by the new one

However, today, I tried to install OM 7.0 on another computer, so I dowloaded from ythe IRCAM site
I had the same message
but this time the link given by Haddad is not valid anymore and gives a 404 on Github
I didn’t find any reference to OMAudioLib.dll on Github

I guess there should ba a new version of OM 7.0 which I miss

Help appreciated

Daniel Schell

Dear Daniel,

The omaudiolib.dll has been updated in the sources on GitHub (not on IRcam site).
And yes this will be a problem if you replace this new one since it is supposed to be for the new 7.1 release.
So here what to do:

  1. Download this from here:
    openmusic/omaudiolib.dll at master · openmusic-project/openmusic · GitHub

  2. just rename exactly the downloaded library as (respect the upper/lower case):

And then replace it.


PS: PLease don’t forget to tag your thread with OpenMusic, if not i will miss it. :slight_smile:

Hello Karim,

Thank you

Your solution worked very well


Hello there,

I’m having the exact problem.
I tried installing the 7.1 version on my windows 11. I get the same error and replacing the omaudiolib.dll doesn’t work either.
However i tried installing the same version on windows 10 and it worked just fine.

Now as these are 2 different computers with different softwares installed on them, i don’t know if this is a windows issue or if i can fix it on my windows 11.

I really appreciate your help.

Dear Bahareh,

Can you send us the specification of your windows 11 machine (cpu, etc.?)

Windows 11
I just downloaded OM 7.1 again
and now nothing works anymore
I can’ even load a workspace anymore, nor in 7.1 neither in 7.0…

Dear Daniel,

Sorry for the late reply.
Did you try uninstalling om7.1 ?

Yes I de-installed 7.0 and de-installled 7.1 several times
Then i re-loaded 7.1 from this address Release OM 7.1 · openmusic-project/openmusic · GitHub
Installation went fine

I started to load the workspaces from Mikhail Malt from my lessons at IRCAM
Sometimes 7.1 works correctly
However sometimes I get a gray Workspace screen, where all the patches disapeared.
Nevertheless, the program still works as I could put a patch.
see the screenshot below

I guess it might just be that some of my files are corrupted

Thanks for the help

Dear Daniel,

First of all, be sure you are installing OM in C:\ disk. If not this will unfortunately not work.
Second, i think it is a workspace problem. Can you send me the workspace in question. I will check it out. Maybe some kind of “alien” type document slipped in .


Hi Haddad
c:\ disk : I work woth OneDrive but the files are use are on C:\ …/ OneDrive / in their local version

Here are two files I have used

‘OM_INTRO_2015_WSPC’ …This one is OK

OO_STAGE_OM_MIKHAIL_WSPC This one is NOT oK . It gives a gray image of the WOrkSpace with out the patches. However the App is functional.

Thanks for the help


Dear Daniel,

Ok, thw workspace was a mess: It included already itself zipped.
I am sending you a clean version. Tell me if it works for you.

00_Stage_OM_perfectionnement_stag_wspc.zip (311.8 KB)


Dear Karim
Thank you so much for your kind help and work
Your file worked perfectly
I just have the V and the P (Play) which do no not work. I have been in he MIDI setup and everfythinh looks OK
Also it claims the library ESQUISSE

Than ks for the help


Dear Daniels,

Concerning the V and the P:
You should use these in lowercase, v for evaluation, and p for play when object is selected.

Concerning the Esquisse library issue:

  1. you can download it from here:
    Release Esquisse 1.2 · openmusic-project/Esquisse · GitHub
    Then check the path to your library folder in the Libraries OM preferences tab.
  2. You can trash the preferences.lisp file you find in the Workspace folder and rerun OM
    You will have freshly preferences according to your environment.


Hello Haddad,

  1. v works OK but p does not produce sound I get ‘Port MIDI ERROR: Port 0 is not connected. Check MIDI preferences’
    However with my other apps it works. It’s just with this WSPC
    2 Esquisse: C:\Program Files (x86)\OpenMusic 7.1\resources\reference do you mean this place to put the library esquisse?
    Thank you very much for the help

This is normal, since the workspace was originally created on a mac i assume.
So just go to the preferences and clic on “Ports setup” as shown below:


Hello Karim
#MIDI issue : Fixed Thank you
#ESQUISSE : Once I find ESQUISSE at GitB-Hub How do I incorporate it in my OM 7.1 Folder.
#ALEA: 7.1 asks me ALEA also, so same question.
Thanks for the help

Dear Daniel,

Once you download Esquisse or any other library, first you SHOULDN’T put it in the OM 7.1 folder. This is not the correct way to add libraries.
Once you install OM, the installer will create automatically a folder in your User’s home named OM. Inside there is a Library folder. THat’s where you should put libraries:

OM will automatically locate this. However you can change the location of your libraries, but you should use the preference panel to locate them:

More about libraries installation here:

Now another thing concerning the Alea library. Once you need to load it, you will have a warning asking you to create the Alea package, just say yes. This is an issue with this library we should fix.