< Back to IRCAM Forum

OM-Csound Error

Hello everyone,

I have the following problem and really don’t know what is the problem; would be grateful to get some help.

I have OM and Csound. Csound works well.
When I open patches which combines OM and Csound (ex. tutorial patches), and press V on a sound source, there comes a pop-up saying me

!!! Error in Csound synthesis !!! .

I checked all the installation path, reinstalled, tried with older versions, nothing works.
Did anyone have this problem too? Where does the problem come from?
I have no problem at launching Csound at all…

(Using a Windows 10 laptop)

thanks :slight_smile:

Hello. Can you be more specific and indicate:
Version of OM
Version of OM2Csound
Version of Csound
Listener outputs (+ check the option “Prisnt system output” in OM/Audio preference for more details in the Listener).
Thanks

Also, check in your OM/Externals preferences that the csound executable path is set correctly.

Hello, I have a similar issue as the original poster. Is it appropriate that I post here, or should I create a separate post of my own?

the issue: My Csound will not open/run. It won’t run as a standalone, nor in OM.

my specs:
OM 6.15
Csound 6.09.1
OS: MacOS HighSierra Version 10.13.6

specifics: I get the following error messages when I attempt to run Csound in the OM Chroma tutorials:
(in OM) !!! Eroor in Csound synthesis !!!
(from my mac) CsoundQt-d-py-cs6 cannot be opened because of a problem. Check with the developer to make sure CsoundQt-d-py-cs6 works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.

I have checked “print system output” in OM/Audio preferences.
I have routed the OM/external “Csound” to the Csound application in my applications folder.
I have also attempted to run the newest version of Csound, and have reached the same problems.

Thank you.

Hi

yes (for the OM part!)

So, the first thing to do is to get Csound running on your computer. Then OM2Csound will do noting but calling it.

However, as far as OM is concerned, you don’t need the whole Csound application but just the command-line tool, which is installed with the default Csound package.

As mentioned in the Csound app error message, I would suggest to install and use the latest updates (current version is 6.13).

You should point to the Csound command-line.
The default install location is /usr/local/bin/csound

Best,

Problem solved!

I had two problems. The first was I had not installed Csound properly (I was copying the application into my computer, without actually running the installation process from the .pckg. The second problem was that I was routing my external to the application. Once I routed it to the local/bin/csound location you wrote, it worked.

Thank you very much!

thank you for the reply!
I have a different problem, my Csound works, but it has a problem running csound through OM despite I set the path correctly.

my versions:
OM 6.15
OM2Csound 2.3
Csound 6.09 (after seeing that 6.13 doesn’t work)

Which path settings must be checked then? I checked the Prisnt system output, nothing changed.

Actually, opening OM files (ORC files) in Csound is working…

thank you for helping! :slight_smile:

Hi,

Probably this is not useful, but are you using stk opcodes? Because in OM you must follow this procedure to have them running: STK user-defined opcodes

Best

fdsdb

so can you copy your listener output here (with this option checked-on) ?

OM > “Start synthesis”
OM > “------ Matrix n. 1 --------”
OM2Csound :: ======================================
OM2Csound :: CSOUND SYNTHESIS…
OM2Csound :: ======================================

Orchestra: #P"C:/PROGRAM FILES (X86)/OM 6.15/WORKSPACE/out-files/add-1_A.orc"
Score: #P"C:/PROGRAM FILES (X86)/OM 6.15/WORKSPACE/out-files/add-1_A.sco"
Output: #P"C:/PROGRAM FILES (X86)/OM 6.15/WORKSPACE/out-files/add-1_A.tmp"
:: “C:\Program Files\Csound6_x64” -f -m7 -A -N -g -b8192 -B8192 “C:\PROGRAM FILES (X86)\OM 6.15\WORKSPACE\out-files\add-1_A.orc” “C:\PROGRAM FILES (X86)\OM 6.15\WORKSPACE\out-files\add-1_A.sco” -o “C:\PROGRAM FILES (X86)\OM 6.15\WORKSPACE\out-files\add-1_A.tmp”
:: '“C:\Program Files\Csound6_x64”'Àº(´Â) ³»ºÎ ¶Ç´Â ¿ÜºÎ ¸í·É, ½ÇÇàÇÒ ¼ö ÀÖ´Â ÇÁ·Î±×·¥, ¶Ç´Â
:: ¹èÄ¡ ÆÄÀÏÀÌ ¾Æ´Õ´Ï´Ù.
OM => #<sound 200F2B57>

…looks bad, doesn’t it?

yes :slight_smile:

but at first signt I would say that your path to Csound exe is probably not the good one. Your command line starts with:

“C:\Program Files\Csound6_x64”

=> I have no Csound install with me right now to check, but inside the Csound_x64 folder you might be able to find csound.exe, which is the actual Csound executable.