< Back to IRCAM Forum

OM 7.2 (and 7.3) not responsive

After uping my system to Monterey on an Intel Mac, OM doesn’t seem to function at all on my machine. I can’t open or create a database, open the prefs window, and when I quit I get a spinning beachball. There are no errors and no menus items (except the OM menu).
I tried OM 7.0, 7.2, and 7.3 (found in another thread here).
I don’t see anyone else mentioning this, is it just me?

I’m on an Intel Mac, upgraded to Monterey maybe 6 months ago, using OM 7.1, everything seems OK so far. Haven’t used OM intensively in a while though.

Fluidsynth/OMplayer is a different story though, I’ve got a thread about that saved for next time I need to grapple with it.

Yeah, figured it was unique to my system since couldn’t find same symptoms on another post. Crap.
Thanks for the heads up about the players. That’s always a challenge! I just launched the R-udp-player patch and was able to get it to sound by itself, though of course can’t test it as an OM player. Hopefully that’ll work!

Dear pbloland,

I am sorry for this.
Are you sure you tried this version:

If yes, are you sure you OS is updated?
And please could you describe WHEN exactly the problem happens.


Hi Karim,
Thanks for the help! Yes, I just re-downloaded from the link you sent and the behavior is the same. The system seems to be fully updated to Monterey - 12.6.6 (21G646).

After launching OM I’m taken straight to the Workspaces dialog. If I choose to “Create a new workspace” and place it in a folder with my other OM workspaces (or anywhere else) the dialog goes away but nothing happens - no folder is created. OM is responsive, but only displays a single menu: OM 7.3. From that menu I can open the About box, but not preferences (selecting that item is simply ignored).
If from the workspaces dialog I select to open an existing workspace, the result is the same: the command is seemingly ignored, leaving OM responsive but with only 1 menu.
I hope that helps! Thanks again,

Quite the same issue on OM7.2 on Linux ubuntu, OM is freezing then I must kill. Unusuable.
I moved from 7.1 to 7.2 in expecting than 7.2 will crash less than 7.1, but it’s worth, I’m sorry.
Moving to a good old OM6 on good old mac 10.8.5 I’m sure everything works as expected.

This seems to be a permission/path issue.
Did you install (copy) OM 73.app in the /Applications folder?

Hi Karim,
I dpkg the .deb from this git repo: Releases · openmusic-project/openmusic · GitHub
is that wrong ?

Dear Fred,

The question was addressed to pboland But i will answer you if you open a new thread please so to avoid conflicting problems and conflicting answers.
Many thanx

Interesting! Yes, it’s in /Applications. My workspaces are in a folder within my user folder, same as always.

can you send me zipped, one of your workspaces that have this issue?
I tried again on my M1 running Monterey, and didn’t have any issue of that sort.
It is just for debugging purpose.
A last question. Are you using a cloud for your workspace?

Sure - I’ll send two. The first (attached) was created when I launched OM - it did allow me to create a new workspace from the opening dialog. I’ve been creating trying to create these in my user folder, but this time created the workspace in my Apps folder. Not sure if that matters.
OM-tester.zip (1.8 KB)

This second one is an older workspace, one that worked just fine previously (before system upgrade). It was located in a folder in my user folder.
Oh - and no, never use the cloud for any kind of workspace, causes too much trouble.
OM-SPLICE-space.zip (24.4 KB)
BTW - it was created in OM 7.0, but that version doesn’t work on my system anymore, with this or any other workspace.

Actually - I stand corrected. If I launch 7.0 or 7.3, it behaves as described - running but no menus, no options. If I then drop an existing .om file onto the app icon, it asks if I want to import that into my workspace. If I say yes, it gives an error the first time (no such file), but then shows me the empty workspace, menus and all! If I drop that same .om file on the app icon again it imports, and I can open it and work! Quitting still locks up the whole thing though. But at least I can work!

Dear pbloland,

First of all, these two things that leads OM to fail launching:

  1. you cannot drag a patch (.omp) on OM icon in order to launch or/and import/open the patch. The correct procedure, is as follows:
  • always launch OM first by clicking the .app icon.
  • then once the workspace is open: ctrl+clic or right clic on the workspace
  • choose import patch (or folder)
  1. Don’t put anything except applications in your /Applications folder. This always leads to problems in general, since it is write protected.

The first workspace (Om-tester) you forwarded has a missing wsparams.lisp file, which leads me to think that the failure was one of the above mentioned maneuvers you did. Anyhow it is empty.

The second workspace (OM-SPLICE-space) looks to me alright. If you cannot open it, do the following:

  1. Make a copy of the workspace
  2. trash the preferences.lisp file inside the workspace folder.
    Try open it by launching first OM, then choose the workspace.

Feel free to report back.


Hi Karim,

Yes, sorry this is getting tangled:

  1. Of course. The procedure you list is what I have been trying, my standard procedure, which unfortunately does not work for me. The ONLY way I can access any patch is by opening OM and then dragging a .om file onto the icon (or I suppose just double clicking the .om file).
  2. Absolutely, my workspaces are (almost) all in my user folder. I just tried putting one someplace else to see if something was wrong with my user permissions.

That empty workspace I forwarded was created when I:

  • Launched OM by double clicking the app icon,
  • from the opening dialog, choose Create new workspace
  • placed that folder in my apps folder (I know I know, bad location! But I tried creating workspaces in lots of locations, the resulting workspaces are identical: empty, no wsparams.lisp file).

I’ll try your procedure with the second workspace (OM-SPLICE-space), which you’ve verified.
Thanks again for your help!

1 Like

Very weird. Are you experiencing other weird issues with other apps? It might be some problem with UID, i am not sure. It seems that you cannot write correctly into folders from OM. And have you some anti-virus running?

Yes, very weird. I’m not experiencing anything else weird with my system, no. Also no anti-virus running.

Also weird: before I could test the procedure you mention above I launched OM 7.3 and quit, and it worked, no spinning beachball. I was suddenly able to open my OM prefs too. And could access my existing workspace for the first time, I didn’t even need to try your procedure.

Then it stoped working, back to the old behavior (after relaunching OM I was unable to open that same workspace). I restarted my Mac, now it works again.

Intermittent failures are the worst! It’s working now though, so I’ll just let you know if it gets in the way again. Let me know if you want more details.

And again, many thanks for your help!

I made a post, maybe Karim can merge it here. It seems related to LispWorks drawing of user interface messages, you can see them in exposé but not drawn in user’s desktop. It all started on Monterey and is independent from architecture…

Ok, my OM class is over. It went well, but I had to bring an iMac to teach OM. It stopped working on my laptop again, and could never get it to launch.

Has there been any progress? I’d still like to use it! (though definitely not as urgent)