< Back to IRCAM Forum

Normalisation in omchroma 5.02


it seems that the normalisation preferences (from the Audio preferences) do not really influence the behaviour of the sound synthesis. This is particularly relevant when synthesising a list coming i.e. from a loop.

Meaning: at the end it will be normalised to 0.0dB, whatever the Audio preference is (even if left unchecked), and only in the case that the peak goes over 0.0dB.

It is not a dramatic issue, since in every test I performed I got “0 samples out of range” from the listener. Adding the keyword “rescale” to the synthesize object works, normalising to the given dB value.

Working on:
OM 6.15
OMChroma 5.02
Csound 10
MacOs 10.13.6


Hello Marco !
Can you try with OMChroma 5.1 and let me know if it works ?

Hello Jean,

it has the same behaviour with 5.1, and I tried also an older one, 4.3, same thing.
From an user’s perspective, it looks like the audio normalisation preferences are “disconnected”.

By the way, one of my students had an occasional “1 sample out of range”, but I need to check what version of CSound she has installed (might be the latest one).


Here is a guess: The “Normalize” option in the OM/Audio Preferences applies (when nothing is explicitly specified with the optional input of synthesize) after the actual synthesis process is over.
I think Csound synthesis might have applied a normalization already at this point: this is the case if -N is in the Csound command line.
You can control the options in the Csound command line from the OM/Externals/Csound “options” preferences.


Thanks Jean, it seems to be as you say. I tried without the -N in the externals options, and it does not normalise anymore. That said, the value given in the Audio preferences seems not to be relevant in any case.

I got the “1 sample out of range” as well. However, adding the keyword “rescale” with i.e. -3dB solved the issue. I think I will control this parameter from here.

Off topic: one weird behaviour of the external options is that even if you change the Csound -A with -W, the file will be saved as .aiff anyways. Again, changing this in the audio preferences seems to have no effect at all.


Yes, the default OM normalization doesn’t take into account the value. I’ve recently added that, so I guess it will work as expected in future versions.

1 Like

I think this is a message from Csound, so before any OM-normalization.

1 Like

That indeed seems like something to fix in OMChroma: by default (if no extension is given to :name) OMChroma passes “----.aiff” as output file name to OM2Csound, so the OM Preference value is not taken into account.

However: this impacts only the file extension: the actual format generated by Csound will still be the one in the command line options.

1 Like

Just gave it a shot. Yes, Audiosculpt recognises my .aiff file as a WAV if the -W is in the command line, and viceversa.

Good to know, thanks Jean!