< Back to IRCAM Forum

Non-latin characters (f.e. Chinese) in patch

Dear OMers,

If you want to write, process and store the non-latin characters (for example Chinese) in OM patch and lisp editor, here could be a temporary solution:

  1. Download this lisp file, and put it into the Application/OM6.19/Contents/Init/ folder.

// I recall this because of several conflicts with workspace and library which may lead to serious problem… If you still have interest, please send me a message and test it only with new workspace and without external library on Mac, with OM 6.19. The new version will be posted after the problem will be solved.

  1. Restart OM and uncheck all the conflicted libraries (unfortunately quite a lot) in preferences, then apply and evtl. restart again.

Here is the screenshot of an error message, but I am not sure about its meaning and the way to debug…

  1. In preferences, set the font of box and comment box to a new font, which contains the character you want to use.
    For example, we could choose the font “Songti SC” for simplified Chinese.

I have tested this in 6.19 with OSX10.14.6 and hope this will not destroy your computer.

Enjoy OM in your language :slight_smile:

Best wishes,

1 Like

Dear Jianlin,

This seems great, thank you! However needs some testing. If all ok i will be happy to integrate it in om (you will have the credits of course!).
Testing on:

  • patches if they re-open.
  • if the font is missing, see the substitution possibilities,
  • all plateforms (OS)

The error you have might be caused by the end of lines and the file encoding. Should test this also.


1 Like

Thank you, Karim!
I am asking friends to test this on different systems and will get back to you later.
There are still conflicts with the different eol styles, both :cl and :crlf could make the error messages… That confuses me a lot and I will try to fix it.

Bonnes vacances,

1 Like