< Back to IRCAM Forum

Modalys crashes with older patches

Hello Robert

are there any news regarding the crashes with my patches I sent you per mail? One crashes on loading another latest, when I turn on the DSP. I would be very happy if this gets solved, because these are two of the patches I did in my video tutorials. And teaching at school is starting up again…would be a pity to avoid modalys…In case anybody else has an idea, what the source might be, I am posting it here:
07_bowPlate.maxpat (23.9 KB)
05_blowTubeWHole.maxpat (16.7 KB)


Hi Olav,
I am unable to reproduce any crash with the latest beta build, that is 3.7.1.b1 dated July 28. Everything works as expected, either on M1 or Intel machines.
Are you sure that is the version you are using?.. (send a “version” message to modalys~)
Is anyone else seeing a crash? (with Olav’s patches.)

ha! reinstall and now it works! why now and not before…I don’t know. I had installed the latest beta…thank you again and sorry…this one seems to be on me…

did you manage to take a look at this? still wondering…

Hi Olav,

We’re making progress!
However yes, this testLua patch stalls Modalys. I will take a close look!


here is another strange one…the console tells me the dimension isn’t right and that “felt” is not implemented yet? however felt works perfectly in other patches…did I completely do something wrong here?
luaPlateHit.maxpat (14.6 KB)