< Back to IRCAM Forum

Modalys~ crash with csound~

Hello !!

I noticed that CSound~ and Modalys~ together in a same patch make Max crash.

I am using:
— MacOS 10.13.6
— Max 8.1.8 (the latest)
— CSound~ v1.1.3(vb+)
— modalys~ (3.6.0.b11, MAX SDK 6.1.4)

Thanks !


@pasquet, may I ask what version of Csound (itself, not the csound~) do you have installed? I had the same problem when I was running Csound 6.11 and when I updated it (to 6.15), the problem was solved.

Here’s the issue post I made at the time in the csound~ GitHub: https://github.com/csound/csound_tilde/issues/13

Hi Olivier,

Could you please provide with the crash log? That’d be helpful.


Hello !

Thanks for your answer !

Max unfortunately does not even have time to leave any proper crash log. I nevertheless can get a crash log whenever Max does not instantly disappear.
This is a 1Mb text file: https://we.tl/t-Y4TGayvokn

It also crashes when I run 2 different Max instances for each external (CSound~ and Modalys~). A common external lib must be called.

Thanks again !!


Hi Olivier,

According to the crash log, it is a hang, not a crash. And neither modalys~ or csound~ are are mentioned in the crash log.
I am trying to download Csound~ for testing purpose but I can’t find a version recent enough (Intel x64). The only recent version is CsoundQT but the Max external is nowhere to be found. Any hint?


Dear Robert,

Here is the latest version (for MacOS):

It should be version v1.1.3(vb+).
I uploaded it here in case you cannot find it (150kB): https://we.tl/t-dJQzvlshhN

You can just instantiate modalys~ and csound~ in a same patcher and you should see Max crashing instantly.

Thank you SO much…


Here is a simple patch where you should replace csound by csound~ to see it crashing.


theolowstein is totally right…

When uploading a version of the problematic csound~.mxo external, I noticed it was very small and concluded that it was calling the actual Csound binary.

As theolowstein wrote:
The problem got solved by updating from Csound 6.11 to Csound 6.15.

— MacOS 10.13.6
— Max 8.1.8
— CSound version 6.15 (double samples) Nov 20 2020
— CSound~ v1.1.3(vb+)
— modalys~ (3.6.0.b11, MAX SDK 6.1.4)
=> WORKS fine

A big congratulations and thanks to theolowstein !!! And thank you for your time Robert.


1 Like

Thank you all!