< Back to IRCAM Forum

MLYS LUA max 8 compatbility with new macs processors or OS?

Hi everyone
I am using Mlys in Max8 and recently put my hands on the lua examples. I am experiencing a series of small issues, which all put together in cascade make it difficult for me to go through the process I’d like to implement.

I have a recent Mac with the new processor, and one of the latest OS. These are working fine. A big thank ro Robert Piechaud for the amazing work done on the new version of Modalys and its implementation in Max, as well as for the new documentation.

I had issues using to read a finite element Modalys script and import it in Max. This was the solution suggested befor Lua came. This which worked perfectely fine in Modalys. I had used Olav Lervik’s tutorials (another warm thank to him, his tutorials are amazing).
I discovered Lua.
I switched to lua to generate the same finite element object, with the same script as our dear Olav.
Quite strangely, I had issues with the Medit application that opens when processing the lua object. It worked perfectly fine with Modalys and Mlys. It would only display the mesh with points. I tried to modify preferences. Since then it won’t open at all.

So, if anyone could let me know if there are any compatibility issues with the latest macs and Os, as well as the procedure to reintitialize Medit without reinstalling the whole Max application and packages, as well as optimizing the whole “bouzin” to make it work safely, I would be so grateful.
Modalys and Max are both wonderful tool ms and I would live to have fun with both of them.
Many thanks
Coralie

@coraliediatkine

I am in a similar M1 configuration and have not had any issues with medit so far.

Hi Coralie,

Could you please upload some file(s) you’re having trouble with?

Thanks!
Robert