< Back to IRCAM Forum

MaxOrch - How To Use Multiphonics and Tam-Tam Datasets?

I have the Multiphonics and Tam Tam datasets from here:


And saved under /Documents/Max 8/Packages/orchidea/db but how do use them as the sample libraries and database with MaxOrch? The aren’t recognised in the 1a / 1b drop down lists.

Also, there doesn’t appear to be any percussion instrument types listed under drop down 2 Orchestra / Instruments list.

Thanks for any pointers!

MaxOrch has been designed for use with SOL databases. 1a and 1b handle this.

To use another database, drag and drop the .db file you want to use.

To choose the instruments, look at their names in the database and enter them by hand in step 2.

Let me know if this works.



Thanks Jerome - so to take the Tam Tam library as an example, what would be the instrument there? All the audio files start with “tt” so should that be the only thing in the Orchestra box under 2?

I get:

orchidea.orchestrate: error: orchidea: orchestration error (empty search space; please check filters)

There is, in fact, a more conventional way of obtaining information from a database

  • Drag and drop the .db file and it should look like this:


  • Then look at the Max console


There’s only one instrument : tt

You can ignore step 3, all styles are used by default.

The error: “orchidea.orchestrate: error: orchidea: orchestration error (empty search space; please check filters)” is the general error message, it is not precise.

There are two ways to see the names of all the instruments in a database.

  1. The first can be seen above, where is says [ instruments tt ]. The tam-tam database is an extreme case since there is only one instrument in the entire db. If you were to load a larger one you’d see the full list there.
  2. Once the database is loaded, you can open the Orchestra window by clicking the “Create Orchestra” button. In the resulting window you’ll find a button called “View All Instruments” (on the right side). Clicking that prints the same list in the text box.

So I get as far as this by dropping the Tam Tam dataset so it shows in 1a and 1b and manually type “tt” and “set orchestra” under 2, when I Relaunch Orchestration I get:

“orchidea.orchestrate: error: orchidea: orchestration error (empty search space; please check filters)”

What might I be missing? Thanks again for your tips and suggestions.

I think I can identify one of the problems, though there might be several. The tam-tam isn’t a terribly pitched instrument, and looking over the samples many don’t have any pitch at all. So that database wouldn’t be terribly effective in replicating pitched targets. When there isn’t enough overlap between target and data in the database, the result is the empty search space error.
To deal with that, here are a couple things to try:

  • make sure you’re loading .mfcc.db, not .spectrum.db (which looks like you are),
  • turn off partialsfiltering (uncheck the box, found in the column of parameters on the right)
  • start with a short target
  • start with the Static Orchestration preset (which it looks like you are)

Next up, follow this procedure for selecting your orchestra:

  • drop the database file on the window in 1b
  • don’t mess with dropdowns 1a or 1b, they’re only useful if you want to load one of the standard dbs
  • click “Create Orchestra” (don’t mess with dropdown 2 either)
  • click the “View All Instruments” button
  • click the “Set Orchestra” button
  • skip 3 (Select Styles) altogether
  • go to 4 to select your target file.

One final thing: I see something very surprising in your screenshot. Dropdown 1a, “Select your sample library…” says “hard-plastic-mallet” in your screenshot. That dropdown should never change contents, it should only list TinySOL2020, OrchideaSOL2020, and FullSOL2020. I don’t think this has anything to do with your results, but I’m curious to know if you altered that manually, or if that was altered due to some bug we don’t know about.

Good luck, and let us know how it goes!

1 Like

Great! That got it. Thans very much for all the tips, following those got it working fine.

I noticed that if I drag the Tam Tam library onto the black field box in 1a or under the first option in 0 that it gives the impression that it loads the library. I thought it seemed odd but was just trying things out in a slightly haphazard way I think :wink:

Thanks again for your help, very much appreciated.

That’s great! Glad it worked.
And - you discovered a bug in MaxOrch, so thanks! It looks like you dragged a folder onto the dropdown, which caused it to repopulate. Which is easy to fix, I just didn’t realize it was possible.

Let us know if you run into any other problems.

1 Like