< Back to IRCAM Forum

Is OM 6.19 broken on Mac OS Monterey?

The program crashes immediately when I open it.

OS 12.0.1
MacBook Pro (M1, 2020)

Hi

Following a report on Lispworks mailing list, Lispworks is not yet ready for Macos Monterey (12) . Om relies on LW. So we must wait for an LW update.
Sorry for that…
By the way, it is always advised NOT to update an OS to its latest release BEFORE being sure that compatibility issues will not be raised.

Best
K

That’s certainly true. Unfortunately, I’m using a shared computer so it wasn’t my choice to update. I suppose it would make the most sense to try restoring to the previous OS rather than wait for a workaround?

Thank you

Dear rmillett,

I am personally waiting for the LispWorks release (8.x) compatible for M1 and new macoses before making the new release of OM 6.20 which is still on hold for this reason.
I heard that it will come soon, but cannot state when. So I let you appreciate the situation. Sorry about this hocus pocus, which is not due to our own will.

Best
K

1 Like

Dear rmillett,

I may have good news. Here is a beta release that should work on monterey using Rosetta II. Can you test it please and report back?

Best regards
K

3 Likes

Well, that is good news.

I installed it and so far it seems to work fine. I need to set up my midi device for playback but the patches seem to be working. Thanks!

Great news!
Thanx for the feedback, and a special thanx for the LispWorks Team.
Soon they are planning a release for native M1 support.

Enjoy
Best
K

Is there a microtonal player you personally recommend for using with OM on Mac OS? I know there are several options but I’m curious which you endorse.

Being a Linux user, i cannot give you a correct answer.
Browsing the topics here, you will find some that satisfy some users. What I know about it, is that it depends if you own a Max environment or not.
It’s a pity that there is not free and efficient one out of the box.

Sorry.

Best
K

It seems the lesson of the week is “use Linux” :slightly_smiling_face:

Perhaps it’s finally time.

Hi,

There’s always the possibility of running an older macOS on a virtual machine. Beyond Oracle’s VirtualBox, VMware has now a free personal license of Fusion Player.

All the best,
António

Dear Antonio,

We were talking about a microplayer. The issue with Mac Monterey is solved (see above).
I will release soon the 6.20 version for all platforms.

best
K

1 Like

Dear Karim,
the version 6.20 starts, but after trying to open my workspace, it says:
An error of type type-error occurred: #\ł (of type character) is not of type base-char.
I tried to delete the preferences.lisp file, but it didn’t help. Also creating a new workspace gives the same error.
I’m on a MB Pro 2020, MacOS Monterey.
all the best
Krzysztof

Dear Krzystof,

I don’t think this is related to Monterey. This kind of error seems more coming from the language set you are using on your system which uses non-latin characters. Can you just try by switching it to english? You could do this temporary in the system preferences-> language and region by adding english.

Best
K

Dear Karim,
thanks for your answer. Tried to switch the system language to English, but after that I got the same error. Version 6.19 worked perfectly under Big Sur. After upgrading to Monterey 6.19 refuse to start. 6.20 starts, but doesn’t read the workspace and gives that error I mentioned.
all the best
Krzysztof

Hi Krzysztof,

Yes this is normal that OM6.19 doesn’t run on Monterey since it wasn’t build for this system. So i still doubt it has something to do with characters issue. Can you just:

  1. open a terminal and type: ls
    the return? and then copy paste the result here, to see.
    It could have something to do with the Path, meaning if you use “special” characters for your folders and such.

best
K

Last login: Sun Nov 14 15:50:01 on console
krzysztofgawlas@MacBook-Pro-Krzysztof ~ % ls
ATS Library Projekty
Applications Movies Public
Audio Music STM32CubeIDE
Desktop OM Spitfire
Documents OM Workspace SuperVP
Downloads OMWork_6.20 VirtualBox VMs
Dropbox Orchidea bin
Dysk Google Pd-L2Ork hvcc
GitHub Pictures macOS-installer
Google Drive Pm2 mutable-dev-environment
krzysztofgawlas@MacBook-Pro-Krzysztof ~ %

Sorry, my bad.
Please do type pwd instead

I’m trying to avoid the nonstandard characters in folders and filenames. I don’t use them in OM because of other problems.

Ok,

Be sure you did put OM 6.20.app in the /Applications folder.
then can you send me a non-working workspace (zipped) so i can see what’s what?

Best
K