< Back to IRCAM Forum

Fluidsynth not recognized on M3 Sonoma 14.5

Hello list,

This is on an M3 Sonoma 14.5 laptop, using a freshly installed OM7.4 for Apple Silicon.
I (re-)installed fluidsynth several times, using brew (after a fresh update), it installed at:


after which I symlinked it like this:

cd /Applications/OM 7.4.app/Contents/Frameworks
ln -s /usr/local/Cellar/fluid-synth/2.3.5/lib/libfluidsynth.3.2.3.dylib libfluidsynth.dylib

lrwxr-xr-x  1 jeroen  admin       65 Jun 29 17:05 libfluidsynth.dylib -> /usr/local/Cellar/fluid-synth/2.3.5/lib/libfluidsynth.3.2.3.dylib
-rw-r--r--@ 1 jeroen  admin    96240 Feb 29 12:53 libportmidi.dylib
-rw-r--r--@ 1 jeroen  admin  1557600 Feb 29 12:53 libsamplerate.dylib
-rw-r--r--@ 1 jeroen  admin   199920 Feb 29 12:53 libsdif.dylib
-rw-r--r--@ 1 jeroen  admin   689920 Feb 29 12:53 libsndfile.dylib
-rw-r--r--@ 1 jeroen  admin  9073760 Feb 29 12:53 omaudiolib.dylib

This didn’t work out, as shown here:

Also, I had been trying to copy the .dylib directly in that directory, with the same negative effect.

I probably am missing out something trivial, so any pointers would be very much welcome!

Thank you so much in advance, Jeroen

ps: reboots didn’t help :frowning:

Sorry for this inconvinience
Did you first removed the existing (original .dylib) first?
Try copying ```

in OM's Frameworks, and rename it as libfluidsynth.dylib
restart OM


Hello K,
Thank you for your fast response!

Yes, I did remove the previous version first, and whilst I had tried your suggestion already, I just tried that again. Alas, the effect is the same. OM Settings notifies fluidsynth is not installed.
Is there a possibility that, under Sonoma14.5, the (notarized?) extension needs to be given permission somewhere?

Best, Jeroen

Back again. I figured it out. My bad for not staying up to date…
So for future reference, I’ll describe the culprit:

Main problem, the transition from Intel to Apple Silicon. In my lazyness of thinking that things will just work, I did not notice that the brew install on Apple Silicon is different. The home on Intel (/usr/local/Cellar, and probably some other variables with it - like CPU :/) is not the same as on ARM (/opt/homebrew). Meaning that it is necessary to save the brew config of the intel machine, and uninstall brew on the arm machine (can be the same as in my case). Then reinstall brew with the saved config. It looks more or less like this:

brew bundle dump // to save the config on the intel machine
/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/uninstall.sh)" // in case it is the same machine uninstall the current brew.
/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)" // install brew on the arm machine
brew bundle install --file Brewfile // reinstall the config 

After that the libfluidsynth.dylib can be installed in the already mentioned way:

cd /Applications/OM\ 7.4.app/Contents/Frameworks
rm libfluid*
ln -s /opt/homebrew/Cellar/fluid-synth/2.3.5/lib/libfluidsynth.3.2.3.dylib libfluidsynth.dylib

And then, I could just start OM7.4 look into settings and fluidsynth shows up there.

Case closed I think.

Best wishes, Jeroen

1 Like