< Back to IRCAM Forum

Error when loading libraries OM7.1 (Windows 11)

I am a very new OM user, so forgive me if I’m asking a solved issue. I’m getting this error when attempting to load several of the basic libraries found on the OM Resources page. I am posting this example as a demonstration because it occurs the same way on different libraries, as you can see the .omlib and .lisp files are present in the folder within the proper library search path which hasn’t been altered from the given zip folder, renaming the files haven’t worked either, so I’m assuming it is something within the files themselves which is causing the issue. Let me know if there is an easy fix for this!

Screenshot 2023-04-27 190852

Thank you.

Hi riohoule,

It seems that OM is looking for Chaos lib and due to windows path it is mistaking the .zip archive for the folder.
In your case I believe you left the .zip in your OM Library folder. So windows interpret the zip file as a folder. Just remove the zip for the OM LIbrary folder.


I should clarify that I did extract the .zip before placing the folder into the library pathway, but I did not change anything that was in the folder once extracted.

Thank you!

I think I found the solution for this issue, it was just a matter of renaming the folder so OM could recognize it. In this case, I just needed to changed the default “Chaos 1.5” to “Chaos” for it to load properly.

I don’t know what did you do while unziping your library, but ‘Chaos 1.5’ should work.