Creating mlys scripts

Is anyone able to generate mlys scrips with the save-script command? I always get the following error: “Error: Foreign function |
modalys_set_variable_internal_name | trying
to call to unresolved external function
“modalys_set_variable_internal_name”.

I am on Modalys 3.5.1b4, and also tried it previously on 3.5.0. My macOS: 10.14.5 (though I’ve tried it on several other earlier OSs). My Modalisp script is dead simple. My save-script command looks like this:
(save-script “/Users/mus/bichord.mlys”)

Apologies: this is a repeat question, but I have yet to have it resolved after months!
Is my problem local only? Or does this feature just not work anymore? Could it have something to do with my filepath? Terminal confirms that’s a viable location…

Any help is much appreciated.

Hi Per,

This is fixed in the latest release (see today’s message).

Best, and thank you for your patience,
Robert

Hi Robert,
Thanks so much for fixing this! Initial tests of the mlys script system look great!
EXCEPT - I now can’t render audio in Modalisp with the (run) and (play) commands. I get an ERROR: error playing sound dialog.
I tried it with my own scripts, and with ex1 - plucked string.lisp, same problem.

Thanks!
Per

Hmm… That is wee queer. Not seen that one.

  1. Which mac OS are you running these days? (checked on 10.12.6 & 10.13.6).
  2. What does ModaLisp’s listener exactly tell?

Robert

I’m on 10.14.5, and don’t think I’ve tried this since upgrading to that some time ago.
When evaluating ex 1 (which runs 2 secs of audio), the listener says:
Generating samples…
[t 0.08, step 3688] Info: pluck: contact
[t 0.19, step 8326] Info: pluck: end contact! (perforation)
[t 1.00, step 44100] … 1.00 seconds until end (load = 1)
[t 2.00, step 88200] … 0.00 seconds until end (load = 1)
… finished computing 2.00 second(s) of sound.
1

I tried Playing Last Synthesis too, and received the same error. I also tried saving it, and that worked fine, I was able to play the saved AIFF in another app.
Hope that helps!
Per

Hi Per,

Thanks for the details. It’s good to hear that the synthesis in itself does happen.
It is being inquired… ( and I really suspect something linked to 10.14).

Stay tuned!
Robert

Hi Per (and Jailin, who seems to have the same problem),

Unfortunately I have not been able to reproduce the “error playing sound” situation so far (even under 10.14). This is kind of frustrating for me.
Have you tried installing Modalys on another machine, just for testing purpose?..

Best,
Robert

Hi Robert,
Sorry for my delay, and sorry you aren’t able to reproduce easily! I’m traveling right now so don’t have access to another machine. I will be sure to give that a try once I’m home in about 2 weeks.

Best,
Per

Robert,
That took me a bit longer than expected, but I did try playing audio on 2 other machines. Neither one had any trouble at all - no errors, rendered audio played back normally. So it appears to be on my machine only.
I double checked about versions: all machines on 10.14.6, and Modalys 3.5.1.rc4.
Per