< Back to IRCAM Forum

Can't re-open OM after omai [SOLVED]

Wanting to install OMAI without succeeding, I therefore removed it from the libraries. But since OM 7.1 no longer opens and I get this message “ERROR: Package OMAI not found.”
Same result after reinstalling OM (I’m on Debian 11)

Dear Lacot,

I am sorry about that.
You don’t need to re-install OM. Wht you need to do is to delete OM main preferences from here:

This should do it.

However, it is strange that you failed to load OMAI lib. I will investigate this and report to its author.

Please do report back.


The OMAI is unfortunately not in a shape where it’s useful for ordinary users yet. I hope to bring it further towards some production-ready some time in the not too far future.

1 Like

If any of you are developting similar tools and libraries in other contexts, and want to join me with making OMAI more complete, please get in touch!

Karim & Anders,
Thank you very much, but it doesn’t work. Here is the OMprefs.lisp:

(in-package :om)(setf omprefs (list (list (quote prev-ws) (om-make-pathname :directory (quote (:absolute “home” “hplinux” “Workspaces” “wkspace-linux”)) :device nil :host nil :name nil :type nil))))

Dear Lacot,

Can you please provide more info ?
ie, do you have the workspace dialog or not?
if yes, can you create a new workspace and use it ?
Do you have any other error dialog?


No, i don’t get the workspace dialog, only the message error. I can’t have any access to OM…

Dear lacot,

Can you provide the openmusic’s log file found in:


“ERROR: Package OMAI not found."

seems OM tries to load a file somewhere in your setup which references the :omai package (which isn’t created before the lib is loaded).

If you remove your .local/share/OpenMusic directory, is it still not working?

Karim & Anders,

Yes, it’s still not working when I remove the OM directory, same result.
Here is the OM log file, as attachment:
openmusic-log (1.1 MB)

One thing though, are you trying to run OM with commadline through the terminal ?
With some environment this will not work. Try running it from the OM.desktop icon.
Another thing, which Window manager are you using?

I already tried both methods, with exactly the same result.
And I am using Gnome.

Dear Lacot,

According to the last log date (reporting problems), you were on Debian 10 on
=== Log at 2022/11/26 22:30:45 ===
The question is: the problem might be when you upgraded to debian 11? Did OM run prior to your usage of the omai lib?
By the way OMAI doesn’t work on OM.


Yes, it worked perfectly, and that’s the raison why I reinstalled OM 7.1.
To be complete, I must say that first I got an OMAI-master which did not open while having access to my workspace. So I deleted the word “master” in the folder name,with same result.

It is on the indications of Jean Bresson, in an old post (21/01/2021), that I replaced OMAI by another OMAI contained in the first, and since I have this blockage.

Sorry, of course I replaced the folder OMAI by the other one.

Dear Lacot,

Did you clean uninstall om using sudo dpkg -r openmusic ?

Please try the following:

  1. download the tar.bz2 archive from here:

  2. Untar it wherever you want (a simple place could be in /home/youraccount/bin/ for instance.) creating a bin directory.

  3. create a script say om71.sh and write the following:


LD_LIBRARY_PATH='.' /home/youraccount/bin/OM_7.1/OM_7.1
  1. make it executable:
    chmod u+x om71.sh

  2. execute the script in a terminal:

this should run. If you run into the same problem, please tell me.


I think the uninstall was not clean enough, since I did’nt use dpkg -r. So, after using this command and and re-install om, it works and I apparently get access to my workspaces. I am only told at the opening,
that omai-master is not found. Yet I am relieved, and I thank you very much.

Great then!
Does the omai warning appears AFTER the launch of the workspace or before?
If it is after, maybe it is the autoload library in your preferences?


It only appeared once, before the launch, when the wksp. was first opened and since then not any more. So far every thing is OK.
Once more, THANKS.