Buffer visibility in imubu

58%20PM

Trouble turning the visibility of specific buffers on/off. Am I misunderstanding the syntax? Example attached; thanks — C

imubu-grains-onoff-test-tut1d.maxpat (116.2 KB)

Hi,
the “inactivebufferindices” is currently broken. It will be fixed in the next release. Its correct behavior is to show inactive buffers in a different color (which you can change with the “inactivebuffercolor” message). Obviously the inactive buffers must also be explicitly excluded from mubu.knn. There is also the possibility of not showing inactive buffers with the “visiblebufferindices” message, but this option does not take into account the hidden buffers for the domain and range values.
Best
Riccardo