< Back to IRCAM Forum

Unable to view object after assigning properties

Dear All —

I have a large finite element object consisting of many sub-meshes, whose geometry evaluates properly but unfortunately I am unable to view in the Medit editor once it’s made into a Modalys object — that is to say, once I’ve assigned all object properties using the familiar form:

(setf my-mesh-object (make-object 'finite-element (mesh my-mesh) [ ...object properties defined here... ] )

I’ve tried both setq and setf here. I can compute the object’s modes, export it as .mesh and/or .modal, but I cannot view the modal object as I can the mesh or various combinations of sub-meshes, using:

(view 'object my-mesh-object)

Instead, in the Listener I’ll get this:

## ERR 0002, inmesh_read, NO INPUT DATA.

I can verify the LISP pointer evaluates properly in the Listener when I define the modal object. Are there any known issues with larger meshes or large sets of sub-meshes? If I go through the normal procedure of making access points, controllers, listening points, playing and running sound, I only obtain the sound of the excitation source (e.g. the sound of a hammer strike), but no resonance from the object whatsoever. I’ve tried various types of objects (mostly metals) with different values for freq-loss and const-loss, but I get the same sonic result each time, and I wonder if this is due to the error at the evaluation step I’ve described above. Or perhaps somehow due to the mesh’s large geometry.

Please let me know if anyone has seen this kind of error or has any tips.

Many thanks, and stay healthy! —

1 Like

Hi Louis !

Actually I never try this function… Usually, I use (view 'mode …) after the modes computation… Did you try it ?

@+ !



Hi Jean! —

Thanks a lot… Yes, I forgot to try this, but (view 'mode …) is working as normal. I’m left wondering if something is still missing since (view 'object …) is not working. Maybe it’s something close to what Jialin was experiencing, but the object itself isn’t throwing errors — maybe it’s a Medit / Modalys issue, but I’m not sure.

The object isn’t really under control yet… I haven’t gotten it to resonate clearly. It’s a lot of large dimensions so I’m wondering if I’m not using enough force (hammer/strike connection), or maybe something is off in my geometry but not causing errors. Some of the sub-meshes vibrate when I run (view 'mode …) with different combinations of modes and oscillations, but not too much of it moves. (make-mesh 'add …) causes no problems, and I’m using high-precision coordinates for all the construction. Well, I’ll keep searching…

I hope you’re doing well during all of this… Wishing you the best, Jean!

@+ ! —