Problem loading OM-pm2

I have a few problems with installing libraries.
Particularly, I can’t get OM-pm2 to work.
I’ve get the superVP and pm2 kernel working, and OM-supervp is working perfectly, but when I try to load the OM-pm2 library, I get this error message:

I tried to rename a file called om7-preferences.lisp that I found in /OM-pm2/sources/ to pm2-prefeferences.lisp.
It meant that the OM-pm2 library now would load, but there would be nothing in the two analysis and synthesis packages, and I couldn’t use any of the content…
Any idea what I’m doing wrong?

Ok, I actually think I fixed by poking around in the OM-pm2.omlib file…
From comparison with OM-pm2.lisp it looked like there was a missing reference to the om-functions.lisp file, and that it was pointing to a non-existing preferences-file in the sources folder.

You’re right: apparently the .omlib file is not up-to-date: it should point to om7-preferences.lisp and incluse “om-functions” as well.
A wrong commit was made on the repository, which reverted this file to an older version of itself.

1 Like

This is fixed now.

I assume you’re using a clone of the repo, but I’ll also post an updated release package someday soon.

1 Like

I am, thanks. it works now!

Hi Jean,

I don’t understand the reason of this question, I have OM-pm2.omlib and it’s the same as the update ? :slight_smile: with the 1.5 version

om-pm2.omlib (1,0 Ko)

Weird, isn’t it ?

Cheers

Jerome

@andersskibsted uses a clone of the source repository (not the distributed/packaged release 1.5). There was a bug in it.

I meant that it’s not a new thing… that’s why I don’t understand why @andersskibsted has this bug…

ok, I understand now !