< Back to IRCAM Forum

Orchidea in Max 7: Unable to Load Externals

Hi,

I’m running Max 7(.2.1) on macOS Mojave 10.14.5.

I recently downloaded the last version(0.5) of the Orchidea package and put it in my Documents/Max 7/Packages/ sub-folder. In the Max console i get the same message for every external (orchidea.solve.mxo, etc.): “unable to load object bundle executable”. Has anyone else had this issue? And, How can I fix it?

Any hints or insights on this issue are most welcome.

All the best,
António

On a side note: no problem in Max 8, though. Every external loaded, I just tested it.
I didn’t test it in Max 6 because, if I recall correctly, the latest versions of the bach package are for Max 7 or higher.

Hi
please make sure that Max 7 is opened in 64 bit mode (this is by default in Max 8)
Best
Carmine

Hi Carmine,

I thought that might be it, but the truth of the matter is that I’m running on macOS Mojave 10.14.5, this implies that I no longer have the option to toggle On or Off “Open in 32-bit mode”.

However, if you or anyone seeing this, has any idea how I can restore that (precious) bit of curatorship over my system, it would be much appreciated.

All the best,
António

Hi Antonio,
I’m pretty positive in saying that it is the 32 bit problem. In Mojave they have just hidden the “open in 32 bit mode” flag, but it is still possible to choose.
I don’t know where it is located now (or which kind of commands you need to type on the prompt) but I know that other users of Orchidea managed in doing this.
Best
Carmine

Hi Carmine,

I didn’t mean to imply that your assessment was wrong, only that it had also crossed my mind but my hands were tied. The only way to open it in 64-bit I’m aware of is to open Max through the Terminal, after that it will always automatically open in 64-bit mode. However, I don’t know how to get back to 32-bit mode, to toggle it back On again. I have a pack of 32-bit oldies but goodies to think about too…

If anyone seeing this has any idea how I can restore that (precious) bit of curatorship over my system, it would be much appreciated.

All the best,
António

Dear Antonio,
thanks for your clarification.
FYI, you need to be sure that max is at 64 to use Orchidea: I was referring to a checkbox previously present in the info panel of a file in OSX called “Open in 32 bit mode” that you would have to uncheck to run Orchidea.
Hope it is clear.

Best
C

Hi,
I have a similar problem: Max 7 can’t recognize the orchidea externals. I am on High Sierra 10.13.6 and using Max 7 (version 7.3.5). I have unchecked the “open in 32 bit mode” flag and Max is correctly running in 64bit.

all the best,
Jouni

hI
Can you send me the exact message given in the Max window?
Thanks
C