Help to install OpenMusic on Linux needed!

Dear Community,
I’m a newbie to Open Music,
but I’m believe that it can bridge my gap between my head and SuperCollider,
I will using it to make experiments in electronic music,
and I’m teach all my self - with the help on your.
So I have the Problem to install the newest stable Version on OpenMusic.
And nobody in my friend-club who can tell me how to do this.
I’m using a Laptop with Linux Ubuntu Studio on it.
I have read that it will give binaries for this nice Program.
But it isn’t to reach this by the Software Manager.
And “sudo apt-get install openmusic” wouldn’t find some data.
So it is my Question:
Could anybody show me to install this Program on this Machine.

CreCo
says thank for all help in advand

Ok,
I’m silly it is the first Blue colored Link on this Site ( near to the top ):
http://repmus.ircam.fr/openmusic/download

So I have installed the deb Package for Linux Ubuntu.
And the deb are seemingly correct installed.
But at I will open the Program,
this Error are produced.
And the Program terminated.:

ERROR: Illegal instruction(4) [code 0] at 7FEB9E623AA0
Unknown foreign code in module “/usr/share/openmusic/resources/lib/linux/OMAudioLib.so” [ #x7FEB9E51D000 ]
rax 7FEB9E95CA20 ; rbx 7FEBA414CA78 ; rcx 7FEBA40008D8 ; rdx 7FEB9EBCBE38
rsp 7FEBB3064AA8 ; rbp 7FEBA414CA80 ; rdi 7FEBA414CA98 ; rsi 7FEBA41D5F80
r8 7FEB9E559D80 ; r9 7FEB9E559D80 ; r10 2F ; r11 7FEB9E37A230
r12 7FEBA414CA98 ; r13 7FEBAC000B20 ; r14 4000049839 ; r15 40E10082CC

Can anybody help me to solve this problem.

A CreCo
who will be nearly fascinated.

Ok dear Community,
I have had a second laptop with:
Linux Ubuntu Mint
on it.
And on this System it will get no Problems to in stall the new version on OpenMusic.
But my:
Linux Ubuntu Studio System ( The System I run my Supercollider on it )
Has Problems with this Audio-Lib.
So it is not a Big Problem, I can create my scores on this machine save them and play it on the other machine. But in respect to mircotonal music, it would be good to connect OpenMusic directly with Supercollider on this other machine.

P.S.: I love OpenMusic !!!

A very happy
CreCo

Generally portmidi is a dependency on Fedora or Linux.

Jonathan (jdm7dv) Moore

Hi Creco. Probably the Ubuntu image i used to build the .deb-package is obsolete. Is your Ubuntu Studio compatible with Ubuntu 18.04.2 LTS?

I’ll build a new .deb based on the current stable version and call back.

Hi Creco. I’ve uploaded a new build of OM_6.15 for Ubuntu 18.04.2.LTS on the releases page at github. This aswell includes a build of OMAudioLib.so done on the same (virtual) box. Please test and tell me how it behaves.

-anders

btw., there’s also a new build, from latest revision @ github, for FC29.