Chord / Chord-seq approximation and MIDI playback

When I’m sending lists of midi-notevalues (in midicents) to a chord or chord-seq I can get them to playback as expected, but no matter if I choose 1/8-tone or 1/4-tone as the approximation chord it still sends the amount of pitchbend for 1/8-tone out to my midiplayback device, and not just the approximated amount for 1/4-tone when that is chosen. For example:

These two situations:

Will give the exact same playback result. I get two notes an 1/8-tone apart played. I send them out on different midi-ports, so it’s not a problem with my setup and the way OM7 allocates microtonal notes on different midi-channels.

When I choose 1/2-tone as the approximation in chord the problem goes away, and it only sends out midi notes in semitone steps, without the pitchbend.

Is this a bug, or is it intended to be that way?
Is there a way I can approximate what is being played only to the 1/4-tones, or do I have to do some rounding in working with lists, before they go in to the chord?

Thanks,
Anders

Hello Anders,

This is sort of what I would expect to happen, but I agree this is not really good. The options for microtonal playback are still quite basic and currently, this playback behaves exactly the same disregarding whether you are in 1/4 or 1/8th tone scale : it plays the “real” (1/8th tone-approximated) pitch in both cases.

I have just fixed that so that you hear what you see : the fix will be included in the next release or update.

In the meantime, you can use approx-m to easily approx incoming pitches to the scale you want.

ps. Also note that this automatic “pitch-bend” tuning process which allows you to hear 1/4 and 1/8th tones is only active if you tick the option “auto microtone bend” in the MIDI preferences. It internally shifts MIDI notes to 4 different channels (1-4).

1 Like

Ok, sounds good.
Yes, it’s never easy how to handle microtuning and midi the best way. But I like the way it’s done now with the pitchbend and different midichannels. I’ve got that to work, with the “auto microtone bend” checked. I’m then just sending out on different midi ports to use different instruments of the IRCAM solo instruments pack in UVI player. It’s running in a max-patch, and actually working quite well, now that I can specify the midi ports on a chord or chord-seq

But thanks, I’ll take a look at approx-m